2008年2月のアーカイブ

Search




TOPページへ

このブログのフィードを取得
[フィードとは]

Powered by
Movable Type 4.23-ja

template by tokyobuddha

 ■■■■■免 責■■■■■
このサイトを参考にしたために発生した一切の損害に「てきとー管理者」は一切関知しませんし、補償もしません。 また、本サイトの記述が正しいことも保証しません。
自己責任にてお願いします。
 -------------------------

Galler Chocolate
ベルギー王室御用達として認定されたチョコレートブランド、ガレー。

岩塩ならクリスタルキンガ
野菜、肉、魚など素材本来の味を引き出します。上質でクセがなく西洋料理はもちろん中華、日本料理にも幅広くお使い頂けます。

玄箱をFedora9-Alpha化 其の八

そういえば、この玄箱は監視サーバ(Nagios)としても使うんだよな~

時間さえ直れば使い続けるんだけど、しばらくは駄目ぽ?

省電力サーバでも調達しようかな、それとも玄箱をもう一台調達しようかな~
悩む・・・・・。

投稿時間: 19:29

玄箱をFedora9-Alpha化 其の七

今、気がついたんだけどsshでログイン後コンソール表示されてた
「 -bash: [: : integer expression expected 」が消えてますね。

いつ直ったの?
そういえば、最近UPDATEが頻繁だからな~

投稿時間: 19:24

玄箱をFedora9-Alpha化 其の六

再起動の原因は「ppc_uartd」では無いかと、にらんでいる。

そこで、stringsで確認してみた。

# strings /usr/sbin/ppc_uartd
/lib/ld.so.1
__gmon_start__
libc.so.6
memcpy
tcflush
system
statfs
select
bzero
cfsetispeed
write
__deregister_frame_info
chdir
cfsetospeed
umask
mktime
signal
read
openlog
closelog
fork
sscanf
gettimeofday
localtime
memset
syslog
__xstat
exit
_IO_stdin_used
__libc_start_main
open
setsid
tcsetattr
__register_frame_info
close
__dso_handle
__cxa_atexit
GLIBC_2.1.3
GLIBC_2.0
}=P.T`
0})[x}=Q.8c
})^0q
P}JJ
=@C0
l}+Kx
}dXP9 B@8
}cXP9 B@8
/dev/ttyS1
can't open UART
uart daemon
error folk
error setsid
error chdir
/mnt
/var/run/smbd.pid
/www/script/melsub_init.sh&
/www/script/melsub_shutdown.sh 2&
/etc/melco/timer_sleep
because it's just after booting up
because now time is re-initialized
because timer file is re-initialized
on<>%2d:%2d<>%2d:%2d%*s
Timer is set with %d/%d %02d:%02d-%d/%d %02d:%02d. (%s)
Timer is released. (%s)
Timer is released. (because timer file isn't able to be read)
can't output value to UART:%c
can't execute program:%s
 
 
 
/www/script/melsub_init.sh こんなの無いぞって事で、玄箱HG(Fedora8)を確認してみると、こちらも無い。
無くてもOKなのか?

/var/run/smbd.pid あれ? sambaなんかインストールしてないし・・・

そこで、ppc_uartdの起動スクリプトを覗いて見た。

# vi /etc/rc.d/init.d/ppc_uartd
==========================================================
#!/bin/sh
#
# UART DAEMON for Link Station
#

PATH=/sbin:/bin:/usr/sbin:/usr/bin

if [ ! -x /usr/sbin/ppc_uartd ] ; then
exit 0
fi

start()
{
echo "Start services: ppc_uartd"
/sbin/start-stop-daemon --start --quiet --exec /usr/sbin/ppc_uartd
}

stop()
{
echo "Stop services: ppc_uartd"
/sbin/start-stop-daemon --stop --quiet --exec /usr/sbin/ppc_uartd
}

case "$1" in
start)
start
;;
stop)
stop
;;
restart)
stop
sleep 1
start
;;
*)
echo "Usage: /etc/init.d/smb {start|stop|restart}" >&2
;;
esac

exit 0
==========================================================

echo "Usage: /etc/init.d/smb {start|stop|restart}" >&2 こんな記述がある。
もしかしてSAMBAがインストールされていて、尚且つ起動していないと駄目なのか?
と、軽い考えでインストール。
そして、起動。

その上で、時刻同期。

 :
 :
 :
 :
 :
 :

やっぱり、5分後に再起動。

考えが浅かった・・・・・^_^;

投稿時間: 17:06

玄箱をFedora9-Alpha化 其の五

時刻を合わせると。必ず5分後に再起動される件は、先日書いたが、その後進展なし・・・。

本日改めて確認を行ってみた。

先ずは時間の確認

現在、2008年 2月 26日 火曜日 16:53:31です。

# clock ← HWの時刻取得
2008年02月27日 01時53分35秒 -0.208173 秒

9時間ずれてる。

# data ← OSでの時刻取得
2008年 2月 27日 水曜日 10:53:31 JST

さらに9時間ずれ。

って事は、現在時刻とOSの時間差は18時間。
なんで?

そこで、再起動覚悟で
# ntpdate "ntpserver" ← 同期させる

さらに

# clock -w ← OSの時刻にHWを合わせる。
 
 
OSとHWの時刻を同期させると・・・・・・

やっぱり、5分後に再起動。

しかし、起動後にOSとHWの時刻を確認すると、HWの時刻は合っている。
ってなると、どのタイミングでHWの時刻が狂う?

謎が深まるばかりだ・・・・・


投稿時間: 16:48

急ぎの仕事がやってきた! → とりあえず終了 っと思ったが・・・。

急ぎの仕事が、とりあえず一段落した。
 
 
 
っと思ったが、また新たに仕事が入りそうぅ。
結構睡眠不足でつらいかも。

そういえば・・・・
最近、玄箱いじってないな~

投稿時間: 18:36

急ぎの仕事がやってきた!

昔の仲間から連絡が入った。
「近日、サーバの設定をお願いしたい。」

内容を聞いてみると・・・・・
「Webサーバ2台、DBサーバ1台、テストサーバ1台。 Webサーバはロードバランスさせ、1台がコケた場合、テストサーバを代替」させたいらしい。
4台の構築は全く問題ないが、ロードバランスはどうなるの?って思っていたら、LVS(Linux Virtual Server)で冗長させるらしい・・・
LVSか~ 高負荷に耐えられるのだろうか~
きちんと冗長するのだろうか~~

色々試して遊んでみようっと!

投稿時間: 23:44

玄箱をFedora9-Alpha化 其の四

少しだけ状況が見えてきた。
OSの時間が相当狂っているので「ntpdate ntp.jst.mfeed.ad.jp」を実行すると、5分後に落ちることが解った。

どこかで、こんな記事を読んだことが有ったな~~
何処だっけ??

投稿時間: 21:28

玄箱をFedora9-Alpha化 其の三

今度は、こんなプランで・・・・

Fedora7化が出来たら、Fedora8にupgradeする。
その後、Fedora9-Alpha化を行う。       懲りないね~~w

■1、Fedora7の環境構築
   方法は、割愛。

■2、yumの不具合解消
   方法は、割愛。

■3、Fedora8へupgrade
   方法は、割愛。
   参考はこちら
   ※基本的なものだけupgradeし、余計なパッケージはインストールは行わない。

■4、Fedora8 になって公式から消えたパッケージ(rpm)を調べる。
# yum install yum-utils  ← yumのユーティリティにインストール
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package yum-utils.noarch 0:1.1.11-1.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
yum-utils noarch 1.1.11-1.fc8 updates 52 k

Transaction Summary
=============================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 52 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): yum-utils-1.1.11-1 100% |=========================| 52 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: yum-utils ######################### [1/1]

Installed: yum-utils.noarch 0:1.1.11-1.fc8
Complete!

そしてチェック。
# package-cleanup --orphans
Setting up yum
kernel-2.6.21-1.3194.fc7.ppc

必要無いので、削除しておきましょう。
# rpm -e kernel-2.6.21-1.3194.fc7

再度確認。
# package-cleanup --orphans
Setting up yum

■5、rpmデータベースの依存関係のチェック
# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
No problems found

■6、二重になっているパッケージの調査
# package-cleanup --dupes
Setting up yum

■7、念のためupdateも確認しておく
# yum update
Setting up Update Process
No Packages marked for Update

■8、yumを綺麗に掃除して、rpmdb の再構築
# yum clean all
Cleaning up Everything

# rm -f /var/lib/rpm/__* ; rpm --rebuilddb

ココまでは問題無く行けるんだよな~~

●9、いよいよFedora9-Alpha化への作業
   先ずは、必要なパッケージをダウンロード。
# wget http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/test/9-Alpha/Fedora
/ppc/os/Packages/fedora-release-8.90-3.noarch.rpm
# wget http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/test/9-Alpha/Fedora
/ppc/os/Packages/fedora-release-notes-8.90-1.noarch.rpm

●10、wgetしたパッケージのインストール(アップデート)
# rpm -Uvh fedora-release-8.90-3.noarch.rpm fedora-release-notes-8.90-1.noarch.rpm
準備中... ########################################### [100%]
1:fedora-release-notes ########################################### [ 50%]
2:fedora-release ########################################### [100%]

●11、念のため掃除
# yum clean all

●12、yumコマンドにて「yum」と「rpm」をFedora9-Alphaのパッケージへupgradeする。
# yum update rpm\* yum\*
development 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 7.1 MB 00:05
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package yum-metadata-parser.ppc 0:1.1.2-7.fc9 set to be updated
--> Processing Dependency: glib2 >= 2.15 for package: yum-metadata-parser
---> Package yum.noarch 0:3.2.11-1.fc9 set to be updated
--> Processing Dependency: pygpgme for package: yum
---> Package rpm-libs.ppc 0:4.4.2.3-0.1.rc1 set to be updated
--> Processing Dependency: libnssutil3.so for package: rpm-libs
---> Package yum-utils.noarch 0:1.1.11-1.fc9 set to be updated
---> Package rpm.ppc 0:4.4.2.3-0.1.rc1 set to be updated
---> Package rpm-python.ppc 0:4.4.2.3-0.1.rc1 set to be updated
--> Running transaction check
---> Package glib2.ppc 0:2.15.5-1.fc9 set to be updated
--> Processing Dependency: libfam.so.0 for package: glib2
---> Package pygpgme.ppc 0:0.1-8.fc9 set to be updated
--> Processing Dependency: libgpgme.so.11(GPGME_1.0) for package: pygpgme
--> Processing Dependency: libgpgme.so.11 for package: pygpgme
---> Package nss.ppc 0:3.11.99.3-1.fc9 set to be updated
--> Processing Dependency: nspr >= 4.6.99 for package: nss
--> Running transaction check
---> Package nspr.ppc 0:4.7-1.fc9 set to be updated
---> Package gpgme.ppc 0:1.1.6-2.fc9 set to be updated
--> Processing Dependency: libpth.so.20 for package: gpgme
--> Processing Dependency: gnupg for package: gpgme
--> Processing Dependency: gnupg2 for package: gpgme
--> Processing Dependency: libgpg-error.so.0 for package: gpgme
---> Package gamin.ppc 0:0.1.9-4.fc8 set to be updated
--> Running transaction check
---> Package libgpg-error.ppc 0:1.6-1 set to be updated
---> Package gnupg2.ppc 0:2.0.8-3.fc9 set to be updated
--> Processing Dependency: pinentry for package: gnupg2
--> Processing Dependency: dirmngr for package: gnupg2
--> Processing Dependency: libgcrypt.so.11 for package: gnupg2
--> Processing Dependency: libusb-0.1.so.4 for package: gnupg2
--> Processing Dependency: libksba.so.8 for package: gnupg2
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: gnupg2
--> Processing Dependency: libcurl.so.4 for package: gnupg2
--> Processing Dependency: libksba.so.8(KSBA_0.9) for package: gnupg2
--> Processing Dependency: libldap-2.4.so.2 for package: gnupg2
---> Package pth.ppc 0:2.0.7-6 set to be updated
---> Package gnupg.ppc 0:1.4.8-1 set to be updated
--> Running transaction check
---> Package libcurl.ppc 0:7.18.0-1.fc9 set to be updated
---> Package dirmngr.ppc 0:1.0.1-2.fc9 set to be updated
--> Processing Dependency: libldap-2.3.so.0 for package: libuser
--> Processing Dependency: libldap-2.3.so.0 for package: nfs-utils
--> Processing Dependency: libldap-2.3.so.0 for package: nfs-utils-lib
---> Package pinentry.ppc 0:0.7.4-1.fc9 set to be updated
---> Package libusb.ppc 0:0.1.12-12.fc9 set to be updated
---> Package libksba.ppc 0:1.0.3-1.fc9 set to be updated
---> Package openldap.ppc 0:2.4.7-7.fc9 set to be updated
--> Processing Dependency: libssl.so.7 for package: openldap
--> Processing Dependency: libcrypto.so.7 for package: openldap
---> Package libgcrypt.ppc 0:1.4.0-1 set to be updated
--> Running transaction check
---> Package libuser.ppc 0:0.56.7-1 set to be updated
---> Package nfs-utils-lib.ppc 0:1.1.1-1.fc9 set to be updated
--> Processing Dependency: libcrypto.so.6 for package: wget
--> Processing Dependency: libcrypto.so.6 for package: python
--> Processing Dependency: libcrypto.so.6 for package: openssh
--> Processing Dependency: libcrypto.so.6 for package: ntp
--> Processing Dependency: libcrypto.so.6 for package: libdhcp6client
--> Processing Dependency: libcrypto.so.6 for package: neon
--> Processing Dependency: libcrypto.so.6 for package: openssh-server
--> Processing Dependency: libcrypto.so.6 for package: vsftpd
--> Processing Dependency: libssl.so.6 for package: wget
--> Processing Dependency: libssl.so.6 for package: neon
--> Processing Dependency: libssl.so.6 for package: vsftpd
--> Processing Dependency: libssl.so.6 for package: python
---> Package nfs-utils.ppc 1:1.1.1-4.fc9 set to be updated
--> Processing Dependency: libevent-1.3e.so.1 for package: nfs-utils
---> Package openssl.ppc 0:0.9.8g-4.fc9 set to be updated
--> Running transaction check
---> Package libdhcp6client.ppc 0:1.0.11-1.fc9 set to be updated
---> Package openssh.ppc 0:4.7p1-8.fc9 set to be updated
---> Package neon.ppc 0:0.28.0-2 set to be updated
--> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package: neon
--> Processing Dependency: libgnutls.so.13 for package: neon
--> Processing Dependency: python = 2.5.1-15.fc8 for package: python-libs
---> Package python.ppc 0:2.5.1-21.fc9 set to be updated
---> Package vsftpd.ppc 0:2.0.5-22.fc9 set to be updated
---> Package openssh-server.ppc 0:4.7p1-8.fc9 set to be updated
---> Package libevent.ppc 0:1.3e-1.fc9 set to be updated
---> Package wget.ppc 0:1.11-1.fc9 set to be updated
---> Package ntp.ppc 0:4.2.4p4-2.fc9 set to be updated
--> Processing Dependency: libdhcp6client-0.10.so.0 for package: mkinitrd
--> Processing Dependency: libdhcp6client-0.10.so.0 for package: libdhcp
--> Processing Dependency: libdhcp6client-0.10.so.0 for package: nash
--> Running transaction check
---> Package libdhcp.ppc 0:1.99.7-2.fc9 set to be updated
--> Processing Dependency: libdhcp4client-4.0.so.0 for package: libdhcp
---> Package nash.ppc 0:6.0.28-4.fc9 set to be updated
--> Processing Dependency: libparted-1.8.so.8 for package: nash
---> Package gnutls.ppc 0:2.0.4-2.fc9 set to be updated
--> Processing Dependency: libtasn1.so.3 for package: gnutls
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3) for package: gnutls
---> Package python-libs.ppc 0:2.5.1-21.fc9 set to be updated
---> Package mkinitrd.ppc 0:6.0.28-4.fc9 set to be updated
--> Processing Dependency: initscripts >= 8.63-1 for package: mkinitrd
--> Running transaction check
---> Package libtasn1.ppc 0:1.1-1.fc8 set to be updated
---> Package parted.ppc 0:1.8.8-3.fc9 set to be updated
---> Package initscripts.ppc 0:8.63-1 set to be updated
---> Package libdhcp4client.ppc 12:4.0.0-10.fc9 set to be updated
--> Processing Conflict: initscripts conflicts mdadm < 2.6.4-3
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package mdadm.ppc 0:2.6.4-3.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
glib2 ppc 2.15.5-1.fc9 development 1.3 M
initscripts ppc 8.63-1 development 1.6 M
libdhcp4client ppc 12:4.0.0-10.fc9 development 295 k
libevent ppc 1.3e-1.fc9 development 55 k
nspr ppc 4.7-1.fc9 development 137 k
nss ppc 3.11.99.3-1.fc9 development 1.2 M
openldap ppc 2.4.7-7.fc9 development 336 k
openssl ppc 0.9.8g-4.fc9 development 1.6 M
parted ppc 1.8.8-3.fc9 development 688 k
rpm ppc 4.4.2.3-0.1.rc1 development 1.2 M
rpm-libs ppc 4.4.2.3-0.1.rc1 development 1.0 M
rpm-python ppc 4.4.2.3-0.1.rc1 development 72 k
yum noarch 3.2.11-1.fc9 development 550 k
yum-metadata-parser ppc 1.1.2-7.fc9 development 29 k
yum-utils noarch 1.1.11-1.fc9 development 52 k
Installing for dependencies:
dirmngr ppc 1.0.1-2.fc9 development 249 k
gamin ppc 0.1.9-4.fc8 development 136 k
gnupg ppc 1.4.8-1 development 2.0 M
gnupg2 ppc 2.0.8-3.fc9 development 2.6 M
gnutls ppc 2.0.4-2.fc9 development 394 k
gpgme ppc 1.1.6-2.fc9 development 318 k
libcurl ppc 7.18.0-1.fc9 development 157 k
libgcrypt ppc 1.4.0-1 development 248 k
libgpg-error ppc 1.6-1 development 72 k
libksba ppc 1.0.3-1.fc9 development 119 k
libtasn1 ppc 1.1-1.fc8 development 292 k
libusb ppc 0.1.12-12.fc9 development 33 k
pinentry ppc 0.7.4-1.fc9 development 65 k
pth ppc 2.0.7-6 development 98 k
pygpgme ppc 0.1-8.fc9 development 33 k
Updating for dependencies:
libdhcp ppc 1.99.7-2.fc9 development 74 k
libdhcp6client ppc 1.0.11-1.fc9 development 95 k
libuser ppc 0.56.7-1 development 489 k
mdadm ppc 2.6.4-3.fc9 development 633 k
mkinitrd ppc 6.0.28-4.fc9 development 100 k
nash ppc 6.0.28-4.fc9 development 161 k
neon ppc 0.28.0-2 development 124 k
nfs-utils ppc 1:1.1.1-4.fc9 development 322 k
nfs-utils-lib ppc 1.1.1-1.fc9 development 68 k
ntp ppc 4.2.4p4-2.fc9 development 1.4 M
openssh ppc 4.7p1-8.fc9 development 297 k
openssh-server ppc 4.7p1-8.fc9 development 286 k
python ppc 2.5.1-21.fc9 development 5.0 M
python-libs ppc 2.5.1-21.fc9 development 632 k
vsftpd ppc 2.0.5-22.fc9 development 147 k
wget ppc 1.11-1.fc9 development 579 k

Transaction Summary
=============================================================================
Install 15 Package(s)
Update 31 Package(s)
Remove 0 Package(s)

Total download size: 27 M
Is this ok [y/N]: y
Downloading Packages:
(1/46): libgcrypt-1.4.0-1 100% |=========================| 248 kB 00:00
(2/46): ntp-4.2.4p4-2.fc9 100% |=========================| 1.4 MB 00:02
(3/46): glib2-2.15.5-1.fc 100% |=========================| 1.3 MB 00:01
(4/46): wget-1.11-1.fc9.p 100% |=========================| 579 kB 00:01
(5/46): openldap-2.4.7-7. 100% |=========================| 336 kB 00:00
(6/46): rpm-4.4.2.3-0.1.r 100% |=========================| 1.2 MB 00:01
(7/46): libksba-1.0.3-1.f 100% |=========================| 119 kB 00:00
(8/46): rpm-libs-4.4.2.3- 100% |=========================| 1.0 MB 00:00
(9/46): libusb-0.1.12-12. 100% |=========================| 33 kB 00:00
(10/46): gnupg-1.4.8-1.pp 100% |=========================| 2.0 MB 00:01
(11/46): pygpgme-0.1-8.fc 100% |=========================| 33 kB 00:00
(12/46): mkinitrd-6.0.28- 100% |=========================| 100 kB 00:00
(13/46): libdhcp4client-4 100% |=========================| 295 kB 00:00
(14/46): yum-metadata-par 100% |=========================| 29 kB 00:00
(15/46): pinentry-0.7.4-1 100% |=========================| 65 kB 00:00
(16/46): gamin-0.1.9-4.fc 100% |=========================| 136 kB 00:00
(17/46): rpm-python-4.4.2 100% |=========================| 72 kB 00:00
(18/46): openssl-0.9.8g-4 100% |=========================| 1.6 MB 00:01
(19/46): yum-utils-1.1.11 100% |=========================| 52 kB 00:00
(20/46): python-libs-2.5. 100% |=========================| 632 kB 00:00
(21/46): nfs-utils-1.1.1- 100% |=========================| 322 kB 00:00
(22/46): gnutls-2.0.4-2.f 100% |=========================| 394 kB 00:00
(23/46): initscripts-8.63 100% |=========================| 1.6 MB 00:01
(24/46): parted-1.8.8-3.f 100% |=========================| 688 kB 00:00
(25/46): libevent-1.3e-1. 100% |=========================| 55 kB 00:00
(26/46): pth-2.0.7-6.ppc. 100% |=========================| 98 kB 00:00
(27/46): openssh-server-4 100% |=========================| 286 kB 00:00
(28/46): gnupg2-2.0.8-3.f 100% |=========================| 2.6 MB 00:06
(29/46): nash-6.0.28-4.fc 100% |=========================| 161 kB 00:00
(30/46): nfs-utils-lib-1. 100% |=========================| 68 kB 00:00
(31/46): yum-3.2.11-1.fc9 100% |=========================| 550 kB 00:00
(32/46): nss-3.11.99.3-1. 100% |=========================| 1.2 MB 00:01
(33/46): mdadm-2.6.4-3.fc 100% |=========================| 633 kB 00:00
(34/46): libuser-0.56.7-1 100% |=========================| 489 kB 00:00
(35/46): nspr-4.7-1.fc9.p 100% |=========================| 137 kB 00:00
(36/46): libdhcp-1.99.7-2 100% |=========================| 74 kB 00:00
(37/46): vsftpd-2.0.5-22. 100% |=========================| 147 kB 00:00
(38/46): python-2.5.1-21. 100% |=========================| 5.0 MB 00:04
(39/46): dirmngr-1.0.1-2. 100% |=========================| 249 kB 00:00
(40/46): libtasn1-1.1-1.f 100% |=========================| 292 kB 00:00
(41/46): gpgme-1.1.6-2.fc 100% |=========================| 318 kB 00:00
(42/46): libcurl-7.18.0-1 100% |=========================| 157 kB 00:00
(43/46): neon-0.28.0-2.pp 100% |=========================| 124 kB 00:00
(44/46): openssh-4.7p1-8. 100% |=========================| 297 kB 00:00
(45/46): libgpg-error-1.6 100% |=========================| 72 kB 00:00
(46/46): libdhcp6client-1 100% |=========================| 95 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : openssl ####################### [ 1/77]
Updating : nspr ####################### [ 2/77]
Updating : nss ####################### [ 3/77]
Updating : openldap ####################### [ 4/77]
Installing: libgpg-error ####################### [ 5/77]
Updating : libdhcp4client ####################### [ 6/77]
Updating : libdhcp6client ####################### [ 7/77]
Updating : libdhcp ####################### [ 8/77]
Installing: libgcrypt ####################### [ 9/77]
Updating : nfs-utils-lib ####################### [10/77]
Updating : parted ####################### [11/77]
Installing: pth ####################### [12/77]
Installing: libksba ####################### [13/77]
Installing: libcurl ####################### [14/77]
Installing: libusb ####################### [15/77]
Updating : libevent ####################### [16/77]
Installing: gnupg ####################### [17/77]
Installing: dirmngr ####################### [18/77]
Installing: pinentry ####################### [19/77]
Installing: gnupg2 ####################### [20/77]
Installing: gpgme ####################### [21/77]
Installing: libtasn1 ####################### [22/77]
Installing: gnutls ####################### [23/77]
Updating : neon ####################### [24/77]
Updating : nfs-utils ####################### [25/77]
Updating : vsftpd ####################### [26/77]
Updating : wget ####################### [27/77]
Updating : ntp ####################### [28/77]
Updating : glib2 ####################### [29/77]
Updating : python ####################### [30/77]
Updating : initscripts ####################### [31/77]
Updating : rpm-libs ####################### [32/77]
Updating : python-libs ####################### [33/77]
Updating : rpm ####################### [34/77]
Updating : rpm-python ####################### [35/77]
Updating : yum-metadata-parser ####################### [36/77]
Updating : mdadm ####################### [37/77]
Installing: pygpgme ####################### [38/77]
Updating : openssh ####################### [39/77]
Updating : libuser ####################### [40/77]
Updating : nash ####################### [41/77]
Installing: gamin ####################### [42/77]
Updating : mkinitrd ####################### [43/77]
Updating : openssh-server ####################### [44/77]
Updating : yum ####################### [45/77]
Updating : yum-utils ####################### [46/77]
Cleanup : libdhcp6client ####################### [47/77]
Cleanup : openssh ####################### [48/77]
Cleanup : neon ####################### [49/77]
Cleanup : python ####################### [50/77]
Cleanup : vsftpd ####################### [51/77]
Cleanup : libdhcp ####################### [52/77]
Cleanup : nspr ####################### [53/77]
Cleanup : libuser ####################### [54/77]
Cleanup : mdadm ####################### [55/77]
Cleanup : nss ####################### [56/77]
Cleanup : yum ####################### [57/77]
Cleanup : nfs-utils-lib ####################### [58/77]
Cleanup : nash ####################### [59/77]
Cleanup : openssh-server ####################### [60/77]
Cleanup : libevent ####################### [61/77]
Cleanup : parted ####################### [62/77]
Cleanup : initscripts ####################### [63/77]
Cleanup : nfs-utils ####################### [64/77]
Cleanup : python-libs ####################### [65/77]
Cleanup : yum-utils ####################### [66/77]
Cleanup : openssl ####################### [67/77]
Cleanup : rpm-python ####################### [68/77]
Cleanup : yum-metadata-parser ####################### [69/77]
Cleanup : libdhcp4client ####################### [70/77]
Cleanup : mkinitrd ####################### [71/77]
Cleanup : rpm-libs ####################### [72/77]
Cleanup : rpm ####################### [73/77]
Cleanup : openldap ####################### [74/77]
Cleanup : wget ####################### [75/77]
Cleanup : glib2 ####################### [76/77]
Cleanup : ntp ####################### [77/77]

Dependency Installed: dirmngr.ppc 0:1.0.1-2.fc9 gamin.ppc 0:0.1.9-4.fc8 gnupg.ppc 0:1.4.8-1 gnupg2.ppc 0:2.0.8-3.fc9 gnutls.ppc 0:2.0.4-2.fc9 gpgme.ppc 0:1.1.6-2.fc9 libcurl.ppc 0:7.18.0-1.fc9 libgcrypt.ppc 0:1.4.0-1 libgpg-error.ppc 0:1.6-1 libksba.ppc 0:1.0.3-1.fc9 libtasn1.ppc 0:1.1-1.fc8 libusb.ppc 0:0.1.12-12.fc9 pinentry.ppc 0:0.7.4-1.fc9 pth.ppc 0:2.0.7-6 pygpgme.ppc 0:0.1-8.fc9
Updated: glib2.ppc 0:2.15.5-1.fc9 initscripts.ppc 0:8.63-1 libdhcp4client.ppc 12:4.0.0-10.fc9 libevent.ppc 0:1.3e-1.fc9 nspr.ppc 0:4.7-1.fc9 nss.ppc 0:3.11.99.3-1.fc9 openldap.ppc 0:2.4.7-7.fc9 openssl.ppc 0:0.9.8g-4.fc9 parted.ppc 0:1.8.8-3.fc9 rpm.ppc 0:4.4.2.3-0.1.rc1 rpm-libs.ppc 0:4.4.2.3-0.1.rc1 rpm-python.ppc 0:4.4.2.3-0.1.rc1 yum.noarch 0:3.2.11-1.fc9 yum-metadata-parser.ppc 0:1.1.2-7.fc9 yum-utils.noarch 0:1.1.11-1.fc9
Dependency Updated: libdhcp.ppc 0:1.99.7-2.fc9 libdhcp6client.ppc 0:1.0.11-1.fc9 libuser.ppc 0:0.56.7-1 mdadm.ppc 0:2.6.4-3.fc9 mkinitrd.ppc 0:6.0.28-4.fc9 nash.ppc 0:6.0.28-4.fc9 neon.ppc 0:0.28.0-2 nfs-utils.ppc 1:1.1.1-4.fc9 nfs-utils-lib.ppc 0:1.1.1-1.fc9 ntp.ppc 0:4.2.4p4-2.fc9 openssh.ppc 0:4.7p1-8.fc9 openssh-server.ppc 0:4.7p1-8.fc9 python.ppc 0:2.5.1-21.fc9 python-libs.ppc 0:2.5.1-21.fc9 vsftpd.ppc 0:2.0.5-22.fc9 wget.ppc 0:1.11-1.fc9
Complete!

なんかいけそうな感じ(^^♪

●13、一気にupgrade
# yum -y upgrade

Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package lvm2.ppc 0:2.02.33-9.fc9 set to be updated
---> Package cracklib.ppc 0:2.8.12-1 set to be updated
---> Package tar.ppc 2:1.19-2.fc9 set to be updated
---> Package pam.ppc 0:0.99.8.1-18.fc9 set to be updated
---> Package libidn.ppc 0:0.6.14-5 set to be updated
---> Package ncurses-libs.ppc 0:5.6-14.20080112.fc9 set to be updated
---> Package binutils.ppc 0:2.18.50.0.3-1 set to be updated
---> Package libacl.ppc 0:2.2.47-1.fc9 set to be updated
---> Package gcc.ppc 0:4.3.0-0.7 set to be updated
--> Processing Dependency: libmpfr.so.1 for package: gcc
--> Processing Dependency: libgmp.so.3 for package: gcc
---> Package ncurses-base.ppc 0:5.6-14.20080112.fc9 set to be updated
---> Package gzip.ppc 0:1.3.12-5.fc9 set to be updated
---> Package shadow-utils.ppc 2:4.1.0-1.fc9 set to be updated
---> Package man-pages.noarch 0:2.76-1.fc9 set to be updated
---> Package glibc-devel.ppc 0:2.7.90-6 set to be updated
---> Package util-linux-ng.ppc 0:2.13.1-3.fc9 set to be updated
---> Package elfutils-libelf.ppc 0:0.132-3.fc9 set to be updated
---> Package iputils.ppc 0:20070202-7.fc9 set to be updated
---> Package psmisc.ppc 0:22.6-3.fc9 set to be updated
---> Package tzdata.noarch 0:2007k-1.fc9 set to be updated
---> Package findutils.ppc 1:4.2.31-4.fc9 set to be updated
---> Package file.ppc 0:4.23-4.fc9 set to be updated
---> Package popt.ppc 0:1.13-1.fc9 set to be updated
---> Package e2fsprogs-libs.ppc 0:1.40.6-1.fc9 set to be updated
---> Package kernel-headers.ppc 0:2.6.25-0.35.rc1.fc9 set to be updated
---> Package librtas.ppc 0:1.3.3-3.fc9 set to be updated
---> Package krb5-libs.ppc 0:1.6.3-4.fc9 set to be updated
---> Package dbus.ppc 0:1.1.4-4.fc9 set to be updated
---> Package coreutils.ppc 0:6.10-5.fc9 set to be updated
---> Package libcap.ppc 0:1.10-33.fc9 set to be updated
---> Package python-iniparse.noarch 0:0.2.3-3.fc9 set to be updated
---> Package device-mapper-libs.ppc 0:1.02.24-9.fc9 set to be updated
---> Package crontabs.noarch 0:1.10-19.fc9 set to be updated
---> Package readline.ppc 0:5.2-10.fc9 set to be updated
---> Package which.ppc 0:2.19-1.fc9 set to be updated
---> Package tcl.ppc 1:8.5.0-6.fc9 set to be updated
---> Package sqlite.ppc 0:3.5.6-1.fc9 set to be updated
--> Processing Dependency: ncurses for package: bash
---> Package libsepol.ppc 0:2.0.20-1.fc9 set to be updated
---> Package file-libs.ppc 0:4.23-4.fc9 set to be updated
---> Package ftp.ppc 0:0.17-45.fc9 set to be updated
---> Package e2fsprogs.ppc 0:1.40.6-1.fc9 set to be updated
---> Package glibc-common.ppc 0:2.7.90-6 set to be updated
---> Package libselinux-python.ppc 0:2.0.53-1.fc9 set to be updated
---> Package zlib.ppc 0:1.2.3-17.fc9 set to be updated
---> Package vim-minimal.ppc 2:7.1.245-1.fc9 set to be updated
---> Package ConsoleKit-libs.ppc 0:0.2.9-1.fc9 set to be updated
---> Package libmudflap.ppc 0:4.3.0-0.7 set to be updated
---> Package cpio.ppc 0:2.9-5.fc9 set to be updated
---> Package ppc64-utils.ppc 0:0.14-1.fc9 set to be updated
--> Processing Dependency: kernel-bootwrapper for package: ppc64-utils
--> Processing Dependency: powerpc-utils for package: ppc64-utils
--> Processing Dependency: ps3pf-utils for package: ppc64-utils
--> Processing Dependency: powerpc-utils-papr for package: ppc64-utils
---> Package mcstrans.ppc 0:0.2.7-2.fc9 set to be updated
---> Package libgcc.ppc 0:4.3.0-0.7 set to be updated
---> Package dhclient.ppc 12:4.0.0-10.fc9 set to be updated
---> Package dmraid.ppc 0:1.0.0.rc14-6.fc9 set to be updated
---> Package audit-libs.ppc 0:1.6.7-2.fc9 set to be updated
---> Package bzip2-libs.ppc 0:1.0.4-13.fc9 set to be updated
---> Package libvolume_id.ppc 0:118-1.fc9 set to be updated
---> Package groff.ppc 0:1.18.1.4-12.fc9 set to be updated
---> Package iptables.ppc 0:1.3.8-6.fc9 set to be updated
---> Package syslog-ng.ppc 0:2.0.8-1.fc9 set to be updated
---> Package glibc.ppc 0:2.7.90-6 set to be updated
---> Package glibc-headers.ppc 0:2.7.90-6 set to be updated
---> Package iproute.ppc 0:2.6.23-3.fc9 set to be updated
--> Processing Dependency: libatm.so.1 for package: iproute
---> Package bzip2.ppc 0:1.0.4-13.fc9 set to be updated
---> Package libstdc++.ppc 0:4.3.0-0.7 set to be updated
---> Package chkconfig.ppc 0:1.3.37-1 set to be updated
---> Package libnl.ppc 0:1.1-1.fc9 set to be updated
---> Package yaboot.ppc 0:1.3.13-9.fc9 set to be updated
---> Package hfsutils.ppc 0:3.2.6-13.fc9 set to be updated
---> Package device-mapper.ppc 0:1.02.24-9.fc9 set to be updated
---> Package libgomp.ppc 0:4.3.0-0.7 set to be updated
---> Package procps.ppc 0:3.2.7-20.fc9 set to be updated
---> Package vim-common.ppc 2:7.1.245-1.fc9 set to be updated
---> Package gawk.ppc 0:3.1.5-16.fc9 set to be updated
---> Package rpcbind.ppc 0:0.1.4-14.fc9 set to be updated
---> Package expat.ppc 0:2.0.1-4 set to be updated
---> Package mingetty.ppc 0:1.08-1.fc9 set to be updated
---> Package bash.ppc 0:3.2-20.fc9 set to be updated
---> Package diffutils.ppc 0:2.8.1-20.fc9 set to be updated
---> Package cracklib-dicts.ppc 0:2.8.12-1 set to be updated
---> Package beecrypt.ppc 0:4.1.2-15 set to be updated
---> Package cyrus-sasl-lib.ppc 0:2.1.22-11.fc9 set to be updated
---> Package libattr.ppc 0:2.4.39-1.fc9 set to be updated
---> Package cpp.ppc 0:4.3.0-0.7 set to be updated
---> Package udev.ppc 0:118-1.fc9 set to be updated
---> Package info.ppc 0:4.11-5.fc9 set to be updated
---> Package kernel.ppc 0:2.6.25-0.35.rc1.fc9 set to be installed
---> Package patch.ppc 0:2.5.4-32.fc9 set to be updated
---> Package libtirpc.ppc 0:0.1.7-14.fc9 set to be updated
---> Package logrotate.ppc 0:3.7.6-3.fc9 set to be updated
---> Package dbus-libs.ppc 0:1.1.4-4.fc9 set to be updated
---> Package libselinux.ppc 0:2.0.53-1.fc9 set to be updated
---> Package less.ppc 0:418-2.fc9 set to be updated
--> Running transaction check
---> Package mpfr.ppc 0:2.3.0-2.fc9 set to be updated
---> Package kernel-bootwrapper.ppc 0:2.6.25-0.35.rc1.fc9 set to be updated
---> Package powerpc-utils.ppc 0:1.0.6-2.fc9 set to be updated
---> Package linux-atm-libs.ppc 0:2.5.0-5 set to be updated
---> Package powerpc-utils-papr.ppc 0:1.0.4-2.fc9 set to be updated
---> Package ncurses.ppc 0:5.6-14.20080112.fc9 set to be updated
---> Package gmp.ppc 0:4.2.2-5.fc9 set to be updated
---> Package ps3pf-utils.ppc 0:2.1-1.fc9 set to be updated
--> Processing Dependency: libps3-utils.so.1 for package: ps3pf-utils
--> Running transaction check
---> Package ps3pf-utils-libs.ppc 0:2.1-1.fc9 set to be updated
filelists.sqlite.bz2 100% |=========================| 11 MB 00:08
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
coreutils ppc 6.10-5.fc9 development 4.6 M
replacing mktemp.ppc 3:1.5-25.fc7

kernel ppc 2.6.25-0.35.rc1.fc9 development 19 M
ncurses-base ppc 5.6-14.20080112.fc9 development 59 k
replacing termcap.noarch 1:5.5-1.20060701.1

ncurses-libs ppc 5.6-14.20080112.fc9 development 366 k
replacing libtermcap.ppc 2.0.8-47

Updating:
ConsoleKit-libs ppc 0.2.9-1.fc9 development 17 k
audit-libs ppc 1.6.7-2.fc9 development 72 k
bash ppc 3.2-20.fc9 development 1.8 M
beecrypt ppc 4.1.2-15 development 128 k
binutils ppc 2.18.50.0.3-1 development 3.2 M
bzip2 ppc 1.0.4-13.fc9 development 51 k
bzip2-libs ppc 1.0.4-13.fc9 development 40 k
chkconfig ppc 1.3.37-1 development 158 k
cpio ppc 2.9-5.fc9 development 188 k
cpp ppc 4.3.0-0.7 development 3.4 M
cracklib ppc 2.8.12-1 development 53 k
cracklib-dicts ppc 2.8.12-1 development 3.8 M
crontabs noarch 1.10-19.fc9 development 7.3 k
cyrus-sasl-lib ppc 2.1.22-11.fc9 development 1.2 M
dbus ppc 1.1.4-4.fc9 development 390 k
dbus-libs ppc 1.1.4-4.fc9 development 137 k
device-mapper ppc 1.02.24-9.fc9 development 70 k
device-mapper-libs ppc 1.02.24-9.fc9 development 66 k
dhclient ppc 12:4.0.0-10.fc9 development 309 k
diffutils ppc 2.8.1-20.fc9 development 221 k
dmraid ppc 1.0.0.rc14-6.fc9 development 625 k
e2fsprogs ppc 1.40.6-1.fc9 development 665 k
e2fsprogs-libs ppc 1.40.6-1.fc9 development 169 k
elfutils-libelf ppc 0.132-3.fc9 development 65 k
expat ppc 2.0.1-4 development 83 k
file ppc 4.23-4.fc9 development 33 k
file-libs ppc 4.23-4.fc9 development 329 k
findutils ppc 1:4.2.31-4.fc9 development 279 k
ftp ppc 0.17-45.fc9 development 63 k
gawk ppc 3.1.5-16.fc9 development 987 k
gcc ppc 4.3.0-0.7 development 6.2 M
glibc ppc 2.7.90-6 development 8.0 M
glibc-common ppc 2.7.90-6 development 27 M
glibc-devel ppc 2.7.90-6 development 2.7 M
glibc-headers ppc 2.7.90-6 development 600 k
groff ppc 1.18.1.4-12.fc9 development 1.9 M
gzip ppc 1.3.12-5.fc9 development 121 k
hfsutils ppc 3.2.6-13.fc9 development 145 k
info ppc 4.11-5.fc9 development 180 k
iproute ppc 2.6.23-3.fc9 development 871 k
iptables ppc 1.3.8-6.fc9 development 327 k
iputils ppc 20070202-7.fc9 development 142 k
kernel-headers ppc 2.6.25-0.35.rc1.fc9 development 669 k
krb5-libs ppc 1.6.3-4.fc9 development 789 k
less ppc 418-2.fc9 development 118 k
libacl ppc 2.2.47-1.fc9 development 25 k
libattr ppc 2.4.39-1.fc9 development 15 k
libcap ppc 1.10-33.fc9 development 32 k
libgcc ppc 4.3.0-0.7 development 54 k
libgomp ppc 4.3.0-0.7 development 53 k
libidn ppc 0.6.14-5 development 219 k
libmudflap ppc 4.3.0-0.7 development 97 k
libnl ppc 1.1-1.fc9 development 154 k
librtas ppc 1.3.3-3.fc9 development 57 k
libselinux ppc 2.0.53-1.fc9 development 132 k
libselinux-python ppc 2.0.53-1.fc9 development 175 k
libsepol ppc 2.0.20-1.fc9 development 138 k
libstdc++ ppc 4.3.0-0.7 development 343 k
libtirpc ppc 0.1.7-14.fc9 development 84 k
libvolume_id ppc 118-1.fc9 development 55 k
logrotate ppc 3.7.6-3.fc9 development 55 k
lvm2 ppc 2.02.33-9.fc9 development 404 k
man-pages noarch 2.76-1.fc9 development 4.3 M
mcstrans ppc 0.2.7-2.fc9 development 19 k
mingetty ppc 1.08-1.fc9 development 21 k
pam ppc 0.99.8.1-18.fc9 development 1.1 M
patch ppc 2.5.4-32.fc9 development 71 k
popt ppc 1.13-1.fc9 development 40 k
ppc64-utils ppc 0.14-1.fc9 development 5.1 k
procps ppc 3.2.7-20.fc9 development 235 k
psmisc ppc 22.6-3.fc9 development 80 k
python-iniparse noarch 0.2.3-3.fc9 development 34 k
readline ppc 5.2-10.fc9 development 197 k
rpcbind ppc 0.1.4-14.fc9 development 55 k
shadow-utils ppc 2:4.1.0-1.fc9 development 1.3 M
sqlite ppc 3.5.6-1.fc9 development 273 k
syslog-ng ppc 2.0.8-1.fc9 development 168 k
tar ppc 2:1.19-2.fc9 development 901 k
tcl ppc 1:8.5.0-6.fc9 development 2.2 M
tzdata noarch 2007k-1.fc9 development 751 k
udev ppc 118-1.fc9 development 286 k
util-linux-ng ppc 2.13.1-3.fc9 development 2.0 M
vim-common ppc 2:7.1.245-1.fc9 development 6.6 M
vim-minimal ppc 2:7.1.245-1.fc9 development 396 k
which ppc 2.19-1.fc9 development 40 k
yaboot ppc 1.3.13-9.fc9 development 173 k
zlib ppc 1.2.3-17.fc9 development 75 k
Installing for dependencies:
gmp ppc 4.2.2-5.fc9 development 240 k
kernel-bootwrapper ppc 2.6.25-0.35.rc1.fc9 development 214 k
linux-atm-libs ppc 2.5.0-5 development 27 k
mpfr ppc 2.3.0-2.fc9 development 165 k
powerpc-utils ppc 1.0.6-2.fc9 development 36 k
powerpc-utils-papr ppc 1.0.4-2.fc9 development 99 k
ps3pf-utils ppc 2.1-1.fc9 development 22 k
ps3pf-utils-libs ppc 2.1-1.fc9 development 19 k
Updating for dependencies:
ncurses ppc 5.6-14.20080112.fc9 development 179 k

Transaction Summary
=============================================================================
Install 12 Package(s)
Update 88 Package(s)
Remove 0 Package(s)

Total download size: 117 M
Downloading Packages:
(1/100): less-418-2.fc9.p 100% |=========================| 118 kB 00:00
(2/100): libselinux-2.0.5 100% |=========================| 132 kB 00:00
(3/100): dbus-libs-1.1.4- 100% |=========================| 137 kB 00:00
(4/100): logrotate-3.7.6- 100% |=========================| 55 kB 00:00
(5/100): libtirpc-0.1.7-1 100% |=========================| 84 kB 00:00
(6/100): ps3pf-utils-2.1- 100% |=========================| 22 kB 00:00
(7/100): patch-2.5.4-32.f 100% |=========================| 71 kB 00:00
(8/100): kernel-2.6.25-0. 100% |=========================| 19 MB 00:17
(9/100): info-4.11-5.fc9. 100% |=========================| 180 kB 00:00
(10/100): udev-118-1.fc9. 100% |=========================| 286 kB 00:00
(11/100): cpp-4.3.0-0.7.p 100% |=========================| 3.4 MB 00:02
(12/100): gmp-4.2.2-5.fc9 100% |=========================| 240 kB 00:00
(13/100): libattr-2.4.39- 100% |=========================| 15 kB 00:00
(14/100): cyrus-sasl-lib- 100% |=========================| 1.2 MB 00:00
(15/100): beecrypt-4.1.2- 100% |=========================| 128 kB 00:00
(16/100): cracklib-dicts- 100% |=========================| 3.8 MB 00:03
(17/100): diffutils-2.8.1 100% |=========================| 221 kB 00:00
(18/100): bash-3.2-20.fc9 100% |=========================| 1.8 MB 00:01
(19/100): mingetty-1.08-1 100% |=========================| 21 kB 00:00
(20/100): expat-2.0.1-4.p 100% |=========================| 83 kB 00:00
(21/100): rpcbind-0.1.4-1 100% |=========================| 55 kB 00:00
(22/100): gawk-3.1.5-16.f 100% |=========================| 987 kB 00:00
(23/100): vim-common-7.1. 100% |=========================| 6.6 MB 00:05
(24/100): procps-3.2.7-20 100% |=========================| 235 kB 00:00
(25/100): libgomp-4.3.0-0 100% |=========================| 53 kB 00:00
(26/100): device-mapper-1 100% |=========================| 70 kB 00:00
(27/100): hfsutils-3.2.6- 100% |=========================| 145 kB 00:00
(28/100): yaboot-1.3.13-9 100% |=========================| 173 kB 00:00
(29/100): libnl-1.1-1.fc9 100% |=========================| 154 kB 00:00
(30/100): chkconfig-1.3.3 100% |=========================| 158 kB 00:00
(31/100): libstdc++-4.3.0 100% |=========================| 343 kB 00:00
(32/100): bzip2-1.0.4-13. 100% |=========================| 51 kB 00:00
(33/100): iproute-2.6.23- 100% |=========================| 871 kB 00:00
(34/100): glibc-headers-2 100% |=========================| 600 kB 00:00
(35/100): glibc-2.7.90-6. 100% |=========================| 8.0 MB 00:06
(36/100): syslog-ng-2.0.8 100% |=========================| 168 kB 00:00
(37/100): iptables-1.3.8- 100% |=========================| 327 kB 00:00
(38/100): groff-1.18.1.4- 100% |=========================| 1.9 MB 00:02
(39/100): libvolume_id-11 100% |=========================| 55 kB 00:00
(40/100): bzip2-libs-1.0. 100% |=========================| 40 kB 00:00
(41/100): audit-libs-1.6. 100% |=========================| 72 kB 00:00
(42/100): dmraid-1.0.0.rc 100% |=========================| 625 kB 00:00
(43/100): dhclient-4.0.0- 100% |=========================| 309 kB 00:00
(44/100): libgcc-4.3.0-0. 100% |=========================| 54 kB 00:00
(45/100): mcstrans-0.2.7- 100% |=========================| 19 kB 00:00
(46/100): ppc64-utils-0.1 100% |=========================| 5.1 kB 00:00
(47/100): cpio-2.9-5.fc9. 100% |=========================| 188 kB 00:00
(48/100): libmudflap-4.3. 100% |=========================| 97 kB 00:00
(49/100): ConsoleKit-libs 100% |=========================| 17 kB 00:00
(50/100): vim-minimal-7.1 100% |=========================| 396 kB 00:00
(51/100): zlib-1.2.3-17.f 100% |=========================| 75 kB 00:00
(52/100): libselinux-pyth 100% |=========================| 175 kB 00:00
(53/100): glibc-common-2. 100% |=========================| 27 MB 00:20
(54/100): e2fsprogs-1.40. 100% |=========================| 665 kB 00:00
(55/100): ftp-0.17-45.fc9 100% |=========================| 63 kB 00:00
(56/100): file-libs-4.23- 100% |=========================| 329 kB 00:00
(57/100): libsepol-2.0.20 100% |=========================| 138 kB 00:00
(58/100): ncurses-5.6-14. 100% |=========================| 179 kB 00:00
(59/100): sqlite-3.5.6-1. 100% |=========================| 273 kB 00:00
(60/100): tcl-8.5.0-6.fc9 100% |=========================| 2.2 MB 00:01
(61/100): which-2.19-1.fc 100% |=========================| 40 kB 00:00
(62/100): readline-5.2-10 100% |=========================| 197 kB 00:00
(63/100): ps3pf-utils-lib 100% |=========================| 19 kB 00:00
(64/100): crontabs-1.10-1 100% |=========================| 7.3 kB 00:00
(65/100): device-mapper-l 100% |=========================| 66 kB 00:00
(66/100): python-iniparse 100% |=========================| 34 kB 00:00
(67/100): libcap-1.10-33. 100% |=========================| 32 kB 00:00
(68/100): coreutils-6.10- 100% |=========================| 4.6 MB 00:03
(69/100): dbus-1.1.4-4.fc 100% |=========================| 390 kB 00:00
(70/100): krb5-libs-1.6.3 100% |=========================| 789 kB 00:00
(71/100): librtas-1.3.3-3 100% |=========================| 57 kB 00:00
(72/100): kernel-headers- 100% |=========================| 669 kB 00:00
(73/100): e2fsprogs-libs- 100% |=========================| 169 kB 00:00
(74/100): popt-1.13-1.fc9 100% |=========================| 40 kB 00:00
(75/100): file-4.23-4.fc9 100% |=========================| 33 kB 00:00
(76/100): findutils-4.2.3 100% |=========================| 279 kB 00:00
(77/100): tzdata-2007k-1. 100% |=========================| 751 kB 00:00
(78/100): psmisc-22.6-3.f 100% |=========================| 80 kB 00:00
(79/100): iputils-2007020 100% |=========================| 142 kB 00:00
(80/100): powerpc-utils-p 100% |=========================| 99 kB 00:00
(81/100): linux-atm-libs- 100% |=========================| 27 kB 00:00
(82/100): elfutils-libelf 100% |=========================| 65 kB 00:00
(83/100): util-linux-ng-2 100% |=========================| 2.0 MB 00:01
(84/100): glibc-devel-2.7 100% |=========================| 2.7 MB 00:02
(85/100): man-pages-2.76- 100% |=========================| 4.3 MB 00:03
(86/100): shadow-utils-4. 100% |=========================| 1.3 MB 00:00
(87/100): gzip-1.3.12-5.f 100% |=========================| 121 kB 00:00
(88/100): ncurses-base-5. 100% |=========================| 59 kB 00:00
(89/100): gcc-4.3.0-0.7.p 100% |=========================| 6.2 MB 00:04
(90/100): libacl-2.2.47-1 100% |=========================| 25 kB 00:00
(91/100): powerpc-utils-1 100% |=========================| 36 kB 00:00
(92/100): kernel-bootwrap 100% |=========================| 214 kB 00:00
(93/100): binutils-2.18.5 100% |=========================| 3.2 MB 00:02
(94/100): ncurses-libs-5. 100% |=========================| 366 kB 00:00
(95/100): libidn-0.6.14-5 100% |=========================| 219 kB 00:00
(96/100): pam-0.99.8.1-18 100% |=========================| 1.1 MB 00:00
(97/100): mpfr-2.3.0-2.fc 100% |=========================| 165 kB 00:00
(98/100): tar-1.19-2.fc9. 100% |=========================| 901 kB 00:00
(99/100): cracklib-2.8.12 100% |=========================| 53 kB 00:00
(100/100): lvm2-2.02.33-9 100% |=========================| 404 kB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : kernel-headers ##################### [ 1/192]
Updating : tzdata ##################### [ 2/192]
Updating : glibc-common ##################### [ 3/192]
Installing: ncurses-base ##################### [ 4/192]
Updating : python-iniparse ##################### [ 5/192]
Updating : man-pages ##################### [ 6/192]
Updating : libgcc ##################### [ 7/192]
Updating : glibc ##################### [ 8/192]
Installing: ncurses-libs ##################### [ 9/192]
Updating : zlib ##################### [ 10/192]
Updating : audit-libs ##################### [ 11/192]
Updating : popt ##################### [ 12/192]
Updating : chkconfig ##################### [ 13/192]
Updating : libcap ##################### [ 14/192]
Updating : libstdc++ ##################### [ 15/192]
Installing: gmp ##################### [ 16/192]
Updating : file-libs ##################### [ 17/192]
Updating : bzip2-libs ##################### [ 18/192]
Updating : libvolume_id ##################### [ 19/192]
Updating : expat ##################### [ 20/192]
Updating : libattr ##################### [ 21/192]
Updating : libacl ##################### [ 22/192]
Updating : libtirpc ##################### [ 23/192]
Installing: mpfr ##################### [ 24/192]
Updating : librtas ##################### [ 25/192]
Updating : libmudflap ##################### [ 26/192]
Updating : ncurses ##################### [ 27/192]
Updating : procps ##################### [ 28/192]
Updating : elfutils-libelf ##################### [ 29/192]
Installing: linux-atm-libs ##################### [ 30/192]
Installing: ps3pf-utils-libs ##################### [ 31/192]
Updating : tcl ##################### [ 32/192]
Updating : libnl ##################### [ 33/192]
Updating : beecrypt ##################### [ 34/192]
Updating : cyrus-sasl-lib ##################### [ 35/192]
Updating : file ##################### [ 36/192]
Updating : mingetty ##################### [ 37/192]
Updating : patch ##################### [ 38/192]
Updating : bash ##################### [ 39/192]
Updating : info ##################### [ 40/192]
Updating : libsepol ##################### [ 41/192]
Updating : libselinux ##################### [ 42/192]
Installing: coreutils ##################### [ 43/192]
Updating : device-mapper-libs ##################### [ 44/192]
Updating : e2fsprogs-libs ##################### [ 45/192]
Updating : readline ##################### [ 46/192]
Updating : device-mapper ##################### [ 47/192]
Updating : binutils ##################### [ 48/192]
Updating : cracklib ##################### [ 49/192]
Updating : glibc-headers ##################### [ 50/192]
Updating : glibc-devel ##################### [ 51/192]
Updating : cracklib-dicts ##################### [ 52/192]
Updating : pam ##################### [ 53/192]
Updating : shadow-utils ##################### [ 54/192]
Updating : libidn ##################### [ 55/192]
Updating : libgomp ##################### [ 56/192]
Updating : logrotate ##################### [ 57/192]
Updating : hfsutils ##################### [ 58/192]
Updating : yaboot ##################### [ 59/192]
Updating : less ##################### [ 60/192]
Updating : udev ##################### [ 61/192]
Updating : dmraid ##################### [ 62/192]
Updating : sqlite ##################### [ 63/192]
Updating : krb5-libs ##################### [ 64/192]
Updating : which ##################### [ 65/192]
Updating : cpp ##################### [ 66/192]
Installing: kernel-bootwrapper ##################### [ 67/192]
Installing: powerpc-utils ##################### [ 68/192]
Installing: powerpc-utils-papr ##################### [ 69/192]
Installing: ps3pf-utils ##################### [ 70/192]
Updating : gcc ##################### [ 71/192]
Updating : gzip ##################### [ 72/192]
Updating : syslog-ng ##################### [ 73/192]
Updating : iputils ##################### [ 74/192]
Updating : rpcbind ##################### [ 75/192]
Updating : lvm2 ##################### [ 76/192]
Updating : e2fsprogs ##################### [ 77/192]
Updating : ftp ##################### [ 78/192]
Updating : groff ##################### [ 79/192]
Updating : gawk ##################### [ 80/192]
Installing: kernel ##################### [ 81/192]
Updating : tar ##################### [ 82/192]
Updating : psmisc ##################### [ 83/192]
Updating : findutils ##################### [ 84/192]
Updating : libselinux-python ##################### [ 85/192]
Updating : vim-minimal ##################### [ 86/192]
Updating : mcstrans ##################### [ 87/192]
Updating : iptables ##################### [ 88/192]
Updating : cpio ##################### [ 89/192]
Updating : diffutils ##################### [ 90/192]
Updating : dhclient ##################### [ 91/192]
Updating : iproute ##################### [ 92/192]
Updating : bzip2 ##################### [ 93/192]
Updating : vim-common ##################### [ 94/192]
Updating : ppc64-utils ##################### [ 95/192]
Updating : crontabs ##################### [ 96/192]
Updating : dbus-libs ##################### [ 97/192]
Updating : dbus ##################### [ 98/192]
Updating : ConsoleKit-libs ##################### [ 99/192]
Updating : util-linux-ng ##################### [100/192]
Cleanup : lvm2 ##################### [101/192]
Cleanup : cracklib ##################### [102/192]
Cleanup : tar ##################### [103/192]
Cleanup : pam ##################### [104/192]
Cleanup : libidn ##################### [105/192]
Cleanup : ncurses ##################### [106/192]
Erasing : libtermcap ##################### [107/192]
Cleanup : binutils ##################### [108/192]
Cleanup : libacl ##################### [109/192]
Cleanup : gcc ##################### [110/192]
Erasing : termcap ##################### [111/192]
Cleanup : gzip ##################### [112/192]
Cleanup : shadow-utils ##################### [113/192]
Cleanup : man-pages ##################### [114/192]
Cleanup : glibc-devel ##################### [115/192]
Cleanup : util-linux-ng ##################### [116/192]
Cleanup : elfutils-libelf ##################### [117/192]
Cleanup : iputils ##################### [118/192]
Cleanup : psmisc ##################### [119/192]
Cleanup : tzdata ##################### [120/192]
Cleanup : findutils ##################### [121/192]
Cleanup : file ##################### [122/192]
Cleanup : popt ##################### [123/192]
Cleanup : e2fsprogs-libs ##################### [124/192]
Cleanup : kernel-headers ##################### [125/192]
Cleanup : librtas ##################### [126/192]
Cleanup : krb5-libs ##################### [127/192]
Cleanup : dbus ##################### [128/192]
Cleanup : coreutils ##################### [129/192]
Erasing : mktemp ##################### [130/192]
Cleanup : libcap ##################### [131/192]
Cleanup : python-iniparse ##################### [132/192]
Cleanup : device-mapper-libs ##################### [133/192]
Cleanup : crontabs ##################### [134/192]
Cleanup : readline ##################### [135/192]
Cleanup : which ##################### [136/192]
Cleanup : tcl ##################### [137/192]
Cleanup : sqlite ##################### [138/192]
Cleanup : libsepol ##################### [139/192]
Cleanup : file-libs ##################### [140/192]
Cleanup : ftp ##################### [141/192]
Cleanup : e2fsprogs ##################### [142/192]
Cleanup : glibc-common ##################### [143/192]
Cleanup : libselinux-python ##################### [144/192]
Cleanup : zlib ##################### [145/192]
Cleanup : vim-minimal ##################### [146/192]
Cleanup : ConsoleKit-libs ##################### [147/192]
Cleanup : libmudflap ##################### [148/192]
Cleanup : cpio ##################### [149/192]
Cleanup : ppc64-utils ##################### [150/192]
Cleanup : mcstrans ##################### [151/192]
Cleanup : libgcc ##################### [152/192]
Cleanup : dhclient ##################### [153/192]
Cleanup : dmraid ##################### [154/192]
Cleanup : audit-libs ##################### [155/192]
Cleanup : bzip2-libs ##################### [156/192]
Cleanup : libvolume_id ##################### [157/192]
Cleanup : groff ##################### [158/192]
Cleanup : iptables ##################### [159/192]
Cleanup : syslog-ng ##################### [160/192]
syslog-ng を停止中: [ OK ]
syslog-ng を起動中: [ OK ]
Cleanup : glibc ##################### [161/192]
Cleanup : glibc-headers ##################### [162/192]
Cleanup : iproute ##################### [163/192]
Cleanup : bzip2 ##################### [164/192]
Cleanup : libstdc++ ##################### [165/192]
Cleanup : chkconfig ##################### [166/192]
Cleanup : libnl ##################### [167/192]
Cleanup : yaboot ##################### [168/192]
Cleanup : hfsutils ##################### [169/192]
Cleanup : device-mapper ##################### [170/192]
Cleanup : libgomp ##################### [171/192]
Cleanup : procps ##################### [172/192]
Cleanup : vim-common ##################### [173/192]
Cleanup : gawk ##################### [174/192]
Cleanup : rpcbind ##################### [175/192]
Cleanup : expat ##################### [176/192]
Cleanup : mingetty ##################### [177/192]
Cleanup : bash ##################### [178/192]
Cleanup : diffutils ##################### [179/192]
Cleanup : cracklib-dicts ##################### [180/192]
Cleanup : beecrypt ##################### [181/192]
Cleanup : cyrus-sasl-lib ##################### [182/192]
Cleanup : libattr ##################### [183/192]
Cleanup : cpp ##################### [184/192]
Cleanup : udev ##################### [185/192]
Cleanup : info ##################### [186/192]
Cleanup : patch ##################### [187/192]
Cleanup : libtirpc ##################### [188/192]
Cleanup : logrotate ##################### [189/192]
Cleanup : dbus-libs ##################### [190/192]
Cleanup : libselinux ##################### [191/192]
Cleanup : less ##################### [192/192]

Installed: coreutils.ppc 0:6.10-5.fc9 kernel.ppc 0:2.6.25-0.35.rc1.fc9 ncurses-base.ppc 0:5.6-14.20080112.fc9 ncurses-libs.ppc 0:5.6-14.20080112.fc9
Dependency Installed: gmp.ppc 0:4.2.2-5.fc9 kernel-bootwrapper.ppc 0:2.6.25-0.35.rc1.fc9 linux-atm-libs.ppc 0:2.5.0-5 mpfr.ppc 0:2.3.0-2.fc9 powerpc-utils.ppc 0:1.0.6-2.fc9 powerpc-utils-papr.ppc 0:1.0.4-2.fc9 ps3pf-utils.ppc 0:2.1-1.fc9 ps3pf-utils-libs.ppc 0:2.1-1.fc9
Updated: ConsoleKit-libs.ppc 0:0.2.9-1.fc9 audit-libs.ppc 0:1.6.7-2.fc9 bash.ppc 0:3.2-20.fc9 beecrypt.ppc 0:4.1.2-15 binutils.ppc 0:2.18.50.0.3-1 bzip2.ppc 0:1.0.4-13.fc9 bzip2-libs.ppc 0:1.0.4-13.fc9 chkconfig.ppc 0:1.3.37-1 cpio.ppc 0:2.9-5.fc9 cpp.ppc 0:4.3.0-0.7 cracklib.ppc 0:2.8.12-1 cracklib-dicts.ppc 0:2.8.12-1 crontabs.noarch 0:1.10-19.fc9 cyrus-sasl-lib.ppc 0:2.1.22-11.fc9 dbus.ppc 0:1.1.4-4.fc9 dbus-libs.ppc 0:1.1.4-4.fc9 device-mapper.ppc 0:1.02.24-9.fc9 device-mapper-libs.ppc 0:1.02.24-9.fc9 dhclient.ppc 12:4.0.0-10.fc9 diffutils.ppc 0:2.8.1-20.fc9 dmraid.ppc 0:1.0.0.rc14-6.fc9 e2fsprogs.ppc 0:1.40.6-1.fc9 e2fsprogs-libs.ppc 0:1.40.6-1.fc9 elfutils-libelf.ppc 0:0.132-3.fc9 expat.ppc 0:2.0.1-4 file.ppc 0:4.23-4.fc9 file-libs.ppc 0:4.23-4.fc9 findutils.ppc 1:4.2.31-4.fc9 ftp.ppc 0:0.17-45.fc9 gawk.ppc 0:3.1.5-16.fc9 gcc.ppc 0:4.3.0-0.7 glibc.ppc 0:2.7.90-6 glibc-common.ppc 0:2.7.90-6 glibc-devel.ppc 0:2.7.90-6 glibc-headers.ppc 0:2.7.90-6 groff.ppc 0:1.18.1.4-12.fc9 gzip.ppc 0:1.3.12-5.fc9 hfsutils.ppc 0:3.2.6-13.fc9 info.ppc 0:4.11-5.fc9 iproute.ppc 0:2.6.23-3.fc9 iptables.ppc 0:1.3.8-6.fc9 iputils.ppc 0:20070202-7.fc9 kernel-headers.ppc 0:2.6.25-0.35.rc1.fc9 krb5-libs.ppc 0:1.6.3-4.fc9 less.ppc 0:418-2.fc9 libacl.ppc 0:2.2.47-1.fc9 libattr.ppc 0:2.4.39-1.fc9 libcap.ppc 0:1.10-33.fc9 libgcc.ppc 0:4.3.0-0.7 libgomp.ppc 0:4.3.0-0.7 libidn.ppc 0:0.6.14-5 libmudflap.ppc 0:4.3.0-0.7 libnl.ppc 0:1.1-1.fc9 librtas.ppc 0:1.3.3-3.fc9 libselinux.ppc 0:2.0.53-1.fc9 libselinux-python.ppc 0:2.0.53-1.fc9 libsepol.ppc 0:2.0.20-1.fc9 libstdc++.ppc 0:4.3.0-0.7 libtirpc.ppc 0:0.1.7-14.fc9 libvolume_id.ppc 0:118-1.fc9 logrotate.ppc 0:3.7.6-3.fc9 lvm2.ppc 0:2.02.33-9.fc9 man-pages.noarch 0:2.76-1.fc9 mcstrans.ppc 0:0.2.7-2.fc9 mingetty.ppc 0:1.08-1.fc9 pam.ppc 0:0.99.8.1-18.fc9 patch.ppc 0:2.5.4-32.fc9 popt.ppc 0:1.13-1.fc9 ppc64-utils.ppc 0:0.14-1.fc9 procps.ppc 0:3.2.7-20.fc9 psmisc.ppc 0:22.6-3.fc9 python-iniparse.noarch 0:0.2.3-3.fc9 readline.ppc 0:5.2-10.fc9 rpcbind.ppc 0:0.1.4-14.fc9 shadow-utils.ppc 2:4.1.0-1.fc9 sqlite.ppc 0:3.5.6-1.fc9 syslog-ng.ppc 0:2.0.8-1.fc9 tar.ppc 2:1.19-2.fc9 tcl.ppc 1:8.5.0-6.fc9 tzdata.noarch 0:2007k-1.fc9 udev.ppc 0:118-1.fc9 util-linux-ng.ppc 0:2.13.1-3.fc9 vim-common.ppc 2:7.1.245-1.fc9 vim-minimal.ppc 2:7.1.245-1.fc9 which.ppc 0:2.19-1.fc9 yaboot.ppc 0:1.3.13-9.fc9 zlib.ppc 0:1.2.3-17.fc9
Dependency Updated: ncurses.ppc 0:5.6-14.20080112.fc9
Replaced: libtermcap.ppc 0:2.0.8-47 mktemp.ppc 3:1.5-25.fc7 ncurses.ppc 0:5.6-12.20070812.fc8 termcap.noarch 1:5.5-1.20060701.1
Complete!

ココまでは、いい感じじゃな~~ぃ!
成功か?

●14、ここで再起動
# reboot

●15、いよいよ確認。
SSHで繋いで見る。

ん?
やっぱり、訳の解らぬメッセージが・・・

Last login: Fri Feb 15 20:25:40 2008 from xxx.yyy.zzz.local
-bash: [: : integer expression expected
[root@kurobox ~]#

前回みたいに、落ちないかを確認。

  :
  :
  :

約7分で落ちる・・・・・・ っと思ったら再起動だった。
もしかして7分毎に再起動(ループ)?

pingで監視している分には落ちないようだ。
そこで、SSHでログインしてみた。

7分経過しても落ちない。

 :
 :
 :

13分後に落ちた。

原因調査中!!

投稿時間: 21:06

玄箱をFedora9-Alpha化 其の二

いきなりのFedora9-Alphaは駄目なのかな~
って事で、再度いきなりFedora9-Alpha化を試してみよう。

手順はこんなか?
玄箱初期化 → Fedora7化 → Fedora9-Alpha化

上手く動くといいけどな~

では、早速作業を行う。

■1、玄箱初期化とFedora7化
玄箱HG Fedora8化への道 №1の手順に従いHDDの初期化。
但し、既存データの削除は[mfdisk]を使って初期化した。
そして、Fedora7化まで完了させる。

■2、yumの不具合の修正
 の
30行目付近の"import Errors"の下に
import md5
を追加。

658行目付近の"self.hdr[rpm.RPMTAG_SIGMD5]"下記の行の下に
if not self.pkgid:
self.pkgid = md5.new(str(self.hdr)).hexdigest()
を追加。

※上記の内容で、正常に動かない場合は次のように変更すると動く場合がある。
+++++++++++++++++++++++++++++++++++++++++++++++++
self.pkgid = self.hdr[rpm.RPMTAG_SHA1HEADER] or \
self.hdr[rpm.RPMTAG_SIGMD5]
if not self.pkgid:
self.pkgid = md5.new(str(self.hdr)).hexdigest()
self.packagesize = self.hdr['size']
self.__mode_cache = {}
self.__prcoPopulated = False
+++++++++++++++++++++++++++++++++++++++++++++++++
   ↓  ↓  ↓ 書き換え
+++++++++++++++++++++++++++++++++++++++++++++++++
self.pkgid = self.hdr[rpm.RPMTAG_SHA1HEADER]
if not self.pkgid:
self.pkgid = self.hdr[rpm.RPMTAG_SIGMD5]
if not self.pkgid:
self.pkgid = md5.new(str(self.hdr)).hexdigest()
self.packagesize = self.hdr['size']
self.__mode_cache = {}
self.__prcoPopulated = False
+++++++++++++++++++++++++++++++++++++++++++++++++

■3、必要なパッケージを取得
# wget http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/test/9-Alpha/Fedora/ppc/os/Packages/
fedora-release-8.90-3.noarch.rpm
  ↑実際は1行で書く
# wget http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/test/9-Alpha/Fedora/ppc/os/Packages/
fedora-release-notes-8.90-1.noarch.rpm
  ↑実際は1行で書く

■3、yumの掃除とupdate
# yum clean all
Loading "installonlyn" plugin
Cleaning up Everything

# yum update rpm\* yum\*
Loading "installonlyn" plugin
Setting up Update Process
development 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 7.1 MB 00:15
Resolving Dependencies
--> Running transaction check
---> Package yum-metadata-parser.ppc 0:1.1.2-7.fc9 set to be updated
filelists.sqlite.bz2 100% |=========================| 11 MB 00:20
http://ftp.kddilabs.jp/Linux/packages/fedora/development/ppc/os/repodata/filelists.sqlite.bz2: [Errno -1] Metadata file does not match checksum
Trying other mirror.
filelists.sqlite.bz2 100% |=========================| 11 MB 00:08
---> Package rpm-libs.ppc 0:4.4.2.3-0.1.rc1 set to be updated
---> Package yum.noarch 0:3.2.11-1.fc9 set to be updated
---> Package rpm.ppc 0:4.4.2.3-0.1.rc1 set to be updated
---> Package rpm-python.ppc 0:4.4.2.3-0.1.rc1 set to be updated
--> Processing Dependency: libplds4.so for package: rpm
--> Processing Dependency: libnss3.so for package: rpm
--> Processing Dependency: libplds4.so for package: rpm-python
--> Processing Dependency: libnss3.so for package: rpm-python
--> Processing Dependency: popt >= 1.10.2.1 for package: rpm
--> Processing Dependency: libplds4.so for package: rpm-libs
--> Processing Dependency: libnss3.so for package: rpm-libs
--> Processing Dependency: libnss3.so(NSS_3.10) for package: rpm-libs
--> Processing Dependency: libnssutil3.so for package: rpm-libs
--> Processing Dependency: python-iniparse for package: yum
--> Processing Dependency: libpopt.so.0(LIBPOPT_0) for package: rpm
--> Processing Dependency: libnspr4.so for package: rpm-libs
--> Processing Dependency: libplc4.so for package: rpm-python
--> Processing Dependency: libpopt.so.0(LIBPOPT_0) for package: rpm-libs
--> Processing Dependency: glib2 >= 2.15 for package: yum-metadata-parser
--> Processing Dependency: libnspr4.so for package: rpm
--> Processing Dependency: libnss3.so(NSS_3.2) for package: rpm-libs
--> Processing Dependency: libnss3.so(NSS_3.4) for package: rpm-libs
--> Processing Dependency: libnssutil3.so for package: rpm
--> Processing Dependency: libnssutil3.so for package: rpm-python
--> Processing Dependency: libplc4.so for package: rpm
--> Processing Dependency: pygpgme for package: yum
--> Processing Dependency: libnspr4.so for package: rpm-python
--> Processing Dependency: libplc4.so for package: rpm-libs
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package nspr.ppc 0:4.7-1.fc9 set to be updated
---> Package glib2.ppc 0:2.15.5-1.fc9 set to be updated
---> Package pygpgme.ppc 0:0.1-8.fc9 set to be updated
---> Package python-iniparse.noarch 0:0.2.3-3.fc9 set to be updated
---> Package popt.ppc 0:1.13-1.fc9 set to be updated
---> Package nss.ppc 0:3.11.99.3-1.fc9 set to be updated
--> Processing Dependency: libgpgme.so.11 for package: pygpgme
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: nss
--> Processing Dependency: libgpgme.so.11(GPGME_1.0) for package: pygpgme
--> Processing Dependency: libfam.so.0 for package: glib2
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package gpgme.ppc 0:1.1.6-2.fc9 set to be updated
---> Package gamin.ppc 0:0.1.9-4.fc8 set to be updated
---> Package glibc.ppc 0:2.7.90-6 set to be updated
--> Processing Dependency: gnupg for package: gpgme
--> Processing Dependency: libpth.so.20 for package: gpgme
--> Processing Dependency: glibc = 2.6-3 for package: glibc-devel
--> Processing Dependency: libgpg-error.so.0 for package: gpgme
--> Processing Dependency: glibc-common = 2.7.90-6 for package: glibc
--> Processing Dependency: gnupg2 for package: gpgme
--> Processing Dependency: glibc = 2.6-3 for package: glibc-headers
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libgpg-error.ppc 0:1.6-1 set to be updated
---> Package glibc-devel.ppc 0:2.7.90-6 set to be updated
---> Package glibc-common.ppc 0:2.7.90-6 set to be updated
---> Package gnupg2.ppc 0:2.0.8-3.fc9 set to be updated
---> Package pth.ppc 0:2.0.7-6 set to be updated
---> Package gnupg.ppc 0:1.4.8-1 set to be updated
---> Package glibc-headers.ppc 0:2.7.90-6 set to be updated
--> Processing Dependency: libgcrypt.so.11 for package: gnupg2
--> Processing Dependency: libcurl.so.4 for package: gnupg
--> Processing Dependency: pinentry for package: gnupg2
--> Processing Dependency: libksba.so.8 for package: gnupg2
--> Processing Dependency: libldap-2.4.so.2 for package: gnupg2
--> Processing Dependency: libksba.so.8(KSBA_0.9) for package: gnupg2
--> Processing Dependency: libusb-0.1.so.4 for package: gnupg2
--> Processing Dependency: libldap-2.4.so.2 for package: gnupg
--> Processing Dependency: libcurl.so.4 for package: gnupg2
--> Processing Dependency: dirmngr for package: gnupg2
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: gnupg2
--> Processing Dependency: libusb-0.1.so.4 for package: gnupg
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libcurl.ppc 0:7.18.0-1.fc9 set to be updated
---> Package dirmngr.ppc 0:1.0.1-2.fc9 set to be updated
---> Package libusb.ppc 0:0.1.12-12.fc9 set to be updated
---> Package openldap.ppc 0:2.4.7-7.fc9 set to be updated
---> Package pinentry.ppc 0:0.7.4-1.fc9 set to be updated
---> Package libksba.ppc 0:1.0.2-4.fc9 set to be updated
---> Package libgcrypt.ppc 0:1.4.0-1 set to be updated
--> Processing Dependency: libldap-2.3.so.0 for package: nfs-utils-lib
--> Processing Dependency: libssl.so.7 for package: openldap
--> Processing Dependency: libcrypto.so.7 for package: openldap
--> Processing Dependency: libldap-2.3.so.0 for package: nfs-utils
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package openssl.ppc 0:0.9.8g-4.fc9 set to be updated
---> Package nfs-utils-lib.ppc 0:1.1.1-1.fc9 set to be updated
---> Package nfs-utils.ppc 1:1.1.1-4.fc9 set to be updated
--> Processing Dependency: libgssglue for package: nfs-utils-lib
--> Processing Dependency: libssl.so.6 for package: neon
--> Processing Dependency: libgssglue.so.1(libgssapi_CITI_2) for package: nfs-utils-lib
--> Processing Dependency: libssl.so.6 for package: wget
--> Processing Dependency: libgssglue for package: nfs-utils
--> Processing Dependency: libgssglue.so.1 for package: nfs-utils-lib
--> Processing Dependency: libgssglue.so.1(libgssapi_CITI_2) for package: nfs-utils
--> Processing Dependency: libgssglue.so.1 for package: nfs-utils
--> Processing Dependency: libevent-1.3e.so.1 for package: nfs-utils
--> Processing Dependency: libcrypto.so.6 for package: libdhcp6client
--> Processing Dependency: libcrypto.so.6 for package: openssh-server
--> Processing Dependency: libssl.so.6 for package: vsftpd
--> Processing Dependency: libcrypto.so.6 for package: ntp
--> Processing Dependency: libssl.so.6 for package: python
--> Processing Dependency: libcrypto.so.6 for package: openssh
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libdhcp6client.ppc 0:1.0.11-1.fc9 set to be updated
---> Package neon.ppc 0:0.28.0-2 set to be updated
---> Package openssh-server.ppc 0:4.7p1-7.fc9 set to be updated
---> Package python.ppc 0:2.5.1-21.fc9 set to be updated
---> Package ntp.ppc 0:4.2.4p4-2.fc9 set to be updated
---> Package openssh.ppc 0:4.7p1-7.fc9 set to be updated
---> Package vsftpd.ppc 0:2.0.5-22.fc9 set to be updated
---> Package libevent.ppc 0:1.3e-1.fc9 set to be updated
---> Package wget.ppc 0:1.11-1.fc9 set to be updated
---> Package libgssglue.ppc 0:0.1-4.fc8 set to be updated
--> Processing Dependency: libdb-4.6.so for package: python
--> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package: neon
--> Processing Dependency: libgnutls.so.13 for package: neon
--> Processing Dependency: libexpat.so.1 for package: python
--> Processing Dependency: libexpat.so.1 for package: neon
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package expat.ppc 0:2.0.1-4 set to be updated
---> Package db4.ppc 0:4.6.21-1.fc8 set to be updated
---> Package gnutls.ppc 0:2.0.4-2.fc9 set to be updated
--> Processing Dependency: libexpat.so.0 for package: dbus
--> Processing Dependency: libtasn1.so.3 for package: gnutls
--> Processing Dependency: libtasn1.so.3(LIBTASN1_0_3) for package: gnutls
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libtasn1.ppc 0:1.1-1.fc8 set to be updated
---> Package dbus-libs.ppc 0:1.1.4-4.fc9 set to be updated
--> Processing Dependency: dbus = 1.1.4-4.fc9 for package: dbus-libs
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package dbus.ppc 0:1.1.4-4.fc9 set to be updated

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
dbus-libs ppc 1.1.4-4.fc9 development 137 k
replacing dbus.ppc 1.0.2-4.fc7

Updating:
rpm ppc 4.4.2.3-0.1.rc1 development 1.2 M
rpm-libs ppc 4.4.2.3-0.1.rc1 development 1.0 M
rpm-python ppc 4.4.2.3-0.1.rc1 development 72 k
yum noarch 3.2.11-1.fc9 development 550 k
yum-metadata-parser ppc 1.1.2-7.fc9 development 29 k
Installing for dependencies:
dirmngr ppc 1.0.1-2.fc9 development 249 k
gamin ppc 0.1.9-4.fc8 development 136 k
gnupg ppc 1.4.8-1 development 2.0 M
gnupg2 ppc 2.0.8-3.fc9 development 2.6 M
gnutls ppc 2.0.4-2.fc9 development 394 k
gpgme ppc 1.1.6-2.fc9 development 318 k
libcurl ppc 7.18.0-1.fc9 development 157 k
libgcrypt ppc 1.4.0-1 development 248 k
libgpg-error ppc 1.6-1 development 72 k
libgssglue ppc 0.1-4.fc8 development 24 k
libksba ppc 1.0.2-4.fc9 development 118 k
libtasn1 ppc 1.1-1.fc8 development 292 k
libusb ppc 0.1.12-12.fc9 development 33 k
nspr ppc 4.7-1.fc9 development 137 k
nss ppc 3.11.99.3-1.fc9 development 1.2 M
pinentry ppc 0.7.4-1.fc9 development 65 k
pth ppc 2.0.7-6 development 98 k
pygpgme ppc 0.1-8.fc9 development 33 k
python-iniparse noarch 0.2.3-3.fc9 development 34 k
Updating for dependencies:
db4 ppc 4.6.21-1.fc8 development 644 k
dbus ppc 1.1.4-4.fc9 development 390 k
expat ppc 2.0.1-4 development 83 k
glib2 ppc 2.15.5-1.fc9 development 1.3 M
glibc ppc 2.7.90-6 development 8.0 M
glibc-common ppc 2.7.90-6 development 27 M
glibc-devel ppc 2.7.90-6 development 2.7 M
glibc-headers ppc 2.7.90-6 development 600 k
libdhcp6client ppc 1.0.11-1.fc9 development 95 k
libevent ppc 1.3e-1.fc9 development 55 k
neon ppc 0.28.0-2 development 124 k
nfs-utils ppc 1:1.1.1-4.fc9 development 322 k
nfs-utils-lib ppc 1.1.1-1.fc9 development 68 k
ntp ppc 4.2.4p4-2.fc9 development 1.4 M
openldap ppc 2.4.7-7.fc9 development 336 k
openssh ppc 4.7p1-7.fc9 development 300 k
openssh-server ppc 4.7p1-7.fc9 development 288 k
openssl ppc 0.9.8g-4.fc9 development 1.6 M
popt ppc 1.13-1.fc9 development 40 k
python ppc 2.5.1-21.fc9 development 5.0 M
vsftpd ppc 2.0.5-22.fc9 development 147 k
wget ppc 1.11-1.fc9 development 579 k

Transaction Summary
=============================================================================
Install 20 Package(s)
Update 27 Package(s)
Remove 0 Package(s)

Total download size: 62 M
Is this ok [y/N]: y
Downloading Packages:
(1/47): libgcrypt-1.4.0-1 100% |=========================| 248 kB 00:00
(2/47): dbus-libs-1.1.4-4 100% |=========================| 137 kB 00:00
(3/47): libksba-1.0.2-4.f 100% |=========================| 118 kB 00:00
(4/47): popt-1.13-1.fc9.p 100% |=========================| 40 kB 00:00
(5/47): libgssglue-0.1-4. 100% |=========================| 24 kB 00:00
(6/47): glib2-2.15.5-1.fc 100% |=========================| 1.3 MB 00:01
(7/47): wget-1.11-1.fc9.p 100% |=========================| 579 kB 00:00
(8/47): rpm-4.4.2.3-0.1.r 100% |=========================| 1.2 MB 00:01
(9/47): glibc-headers-2.7 100% |=========================| 600 kB 00:00
(10/47): rpm-libs-4.4.2.3 100% |=========================| 1.0 MB 00:01
(11/47): gnupg-1.4.8-1.pp 100% |=========================| 2.0 MB 00:01
(12/47): glibc-2.7.90-6.p 100% |=========================| 8.0 MB 00:06
(13/47): libevent-1.3e-1. 100% |=========================| 55 kB 00:00
(14/47): yum-metadata-par 100% |=========================| 29 kB 00:00
(15/47): pinentry-0.7.4-1 100% |=========================| 65 kB 00:00
(16/47): gamin-0.1.9-4.fc 100% |=========================| 136 kB 00:00
(17/47): pth-2.0.7-6.ppc. 100% |=========================| 98 kB 00:00
(18/47): libtasn1-1.1-1.f 100% |=========================| 292 kB 00:00
(19/47): vsftpd-2.0.5-22. 100% |=========================| 147 kB 00:00
(20/47): openssh-4.7p1-7. 100% |=========================| 300 kB 00:00
(21/47): nfs-utils-1.1.1- 100% |=========================| 322 kB 00:00
(22/47): gnutls-2.0.4-2.f 100% |=========================| 394 kB 00:00
(23/47): ntp-4.2.4p4-2.fc 100% |=========================| 1.4 MB 00:01
(24/47): rpm-python-4.4.2 100% |=========================| 72 kB 00:00
(25/47): gnupg2-2.0.8-3.f 100% |=========================| 2.6 MB 00:02
(26/47): glibc-common-2.7 100% |=========================| 27 MB 00:22
(27/47): openldap-2.4.7-7 100% |=========================| 336 kB 00:00
(28/47): nfs-utils-lib-1. 100% |=========================| 68 kB 00:00
(29/47): yum-3.2.11-1.fc9 100% |=========================| 550 kB 00:00
(30/47): nss-3.11.99.3-1. 100% |=========================| 1.2 MB 00:01
(31/47): openssl-0.9.8g-4 100% |=========================| 1.6 MB 00:01
(32/47): db4-4.6.21-1.fc8 100% |=========================| 644 kB 00:00
(33/47): nspr-4.7-1.fc9.p 100% |=========================| 137 kB 00:00
(34/47): expat-2.0.1-4.pp 100% |=========================| 83 kB 00:00
(35/47): python-iniparse- 100% |=========================| 34 kB 00:00
(36/47): python-2.5.1-21. 100% |=========================| 5.0 MB 00:04
(37/47): openssh-server-4 100% |=========================| 288 kB 00:00
(38/47): glibc-devel-2.7. 100% |=========================| 2.7 MB 00:02
(39/47): pygpgme-0.1-8.fc 100% |=========================| 33 kB 00:00
(40/47): libusb-0.1.12-12 100% |=========================| 33 kB 00:00
(41/47): dbus-1.1.4-4.fc9 100% |=========================| 390 kB 00:00
(42/47): gpgme-1.1.6-2.fc 100% |=========================| 318 kB 00:00
(43/47): dirmngr-1.0.1-2. 100% |=========================| 249 kB 00:00
(44/47): libcurl-7.18.0-1 100% |=========================| 157 kB 00:00
(45/47): neon-0.28.0-2.pp 100% |=========================| 124 kB 00:00
(46/47): libgpg-error-1.6 100% |=========================| 72 kB 00:00
(47/47): libdhcp6client-1 100% |=========================| 95 kB 00:00
Running Transaction Test
warning: db4-4.6.21-1.fc8: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : glibc-common ####################### [ 1/75]
Updating : glibc [ 2/75]warning: /etc/localtime created as /etc/localtime.rpmnew
Updating : glibc ####################### [ 2/75]
Updating : openssl ####################### [ 3/75]
Updating : openldap ####################### [ 4/75]
Updating : popt ####################### [ 5/75]
Installing: libgpg-error ####################### [ 6/75]
Installing: nspr ####################### [ 7/75]
Installing: nss ####################### [ 8/75]
Installing: libgcrypt ####################### [ 9/75]
Updating : expat ####################### [10/75]
Installing: pth ####################### [11/75]
Installing: libcurl ####################### [12/75]
Installing: libksba ####################### [13/75]
Installing: libusb ####################### [14/75]
Updating : glibc-headers ####################### [15/75]
Installing: libgssglue ####################### [16/75]
Updating : nfs-utils-lib ####################### [17/75]
Installing: gnupg ####################### [18/75]
Installing: dirmngr ####################### [19/75]
Updating : openssh ####################### [20/75]
Updating : db4 ####################### [21/75]
Updating : python ####################### [22/75]
Installing: python-iniparse ####################### [23/75]
Installing: libtasn1 ####################### [24/75]
Installing: gnutls ####################### [25/75]
Installing: pinentry ####################### [26/75]
Installing: gnupg2 ####################### [27/75]

動きが止まる・・・・・。
topにて確認をするが、動いてる感じなんだよな~
===============================================================
top - 12:05:38 up 44 min, 2 users, load average: 1.00, 1.00, 0.87
Tasks: 31 total, 2 running, 29 sleeping, 0 stopped, 0 zombie
Cpu(s): 92.7%us, 7.3%sy, 0.0%ni, 0.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 62096k total, 60688k used, 1408k free, 5812k buffers
Swap: 524656k total, 46792k used, 477864k free, 37644k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
1958 root 25 0 72000 9772 3300 R 98.9 15.7 24:40.44 yum
===============================================================

その後、1時間程放置したが、全く進まず・・・・
ダァ~!

投稿時間: 14:31

玄箱をFedora9-Alpha化 其の一

先日、玄箱Fedora8をFedora9-Alpha化して、訳の解らないエラーが出た。
ネットで色々探したが、有力な情報が無かった。

原因追求が出来ず、気持ち悪いが新規でFedora9-Alpha化してみようと思う。

++++ その前に今回のハード構成 +++++++++++++++++++++++++++
筐体  : 玄箱(初期型)
HDD  : Maxtor DiamondMax Plus9 120GB ATA/133
            (6Y120P0131211) 7200rpm、バッファ8MB
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++

先ずは、事前準備。
「玄箱Fedora8化への道 №1」と同じ要領で、初期化。
※今回は、EMモード時に「mfdisk -c /dev/hda」で初期化を行った。
  ケースからHDDを外さなくても良いので、手軽に初期化できますね。
そしてFedora7化まで進める。

 :
 :
 :

完了したら、rootのパスワードを変更。

そして、いよいよFedora9-Alpha化。

■1、Fedora8の必要パッケージをGetする。
   Fedora8のPPCのサイトへ行き、次の2つをwget

入手先
http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/test/9-Alpha/Fedora/ppc/os/Packages/

・fedora-release-8.90-3.noarch.rpm
・fedora-release-notes-8.90-1.noarch.rpm

■2、/usr/lib/python2.5/site-packages/yum/packages.pyを一部変更する。
=====================================================
30行目付近の"import Errors"の下に
import md5
を追加。

658行目付近の"self.hdr[rpm.RPMTAG_SIGMD5]"下記の行の下に
if not self.pkgid:
self.pkgid = md5.new(str(self.hdr)).hexdigest()
を追加。
=====================================================
これで上手く動くはず。
だったが、今回は上手く動かない・・・

そこで、Fedora8化をしてる玄箱HGの内容を確認する。
UPDATEされて、若干変わっている。
駄目もとで、同じ設定に変えてみる。
self.hdr = hdr から self.__prcoPopulated = False の間を下記のように変更。

=====================================================
self.hdr = hdr
self.name = self.hdr['name']
self.arch = self.hdr['arch']
self.epoch = self.doepoch()
self.version = self.hdr['version']
self.release = self.hdr['release']
self.ver = self.version
self.rel = self.release
self.summary = self.hdr['summary'].replace('\n', '')
self.description = self.hdr['description']
self.pkgid = self.hdr[rpm.RPMTAG_SHA1HEADER]
if not self.pkgid:
self.pkgid = "%s.%s" %(self.hdr['name'], self.hdr['buildtime'])
self.packagesize = self.hdr['size']
self.__mode_cache = {}
self.__prcoPopulated = False
=====================================================

■3、yum update yum* rpm*を実行
Loading "installonlyn" plugin
Setting up Update Process
Could not find update match for rpmsack.pyc
Could not find update match for yumRepo.pyo
Could not find update match for yumRepo.py
Could not find update match for rpmsack.pyo
Could not find update match for yumRepo.pyc
Could not find update match for rpmsack.py
No Packages marked for Update/Obsoletion

この方法では駄目かな??

投稿時間: 10:18

iDCでの作業

二日間に渡りiDC内でメンテナンスを行っていた。
2UマシンのRAID回りの不具合でOSが勝手にリブートしてしまうためだ。

メーカー保守が「翌日対応」のサポートだったため、無駄な時間を使ってしまった。

このiDCは「サーバには良い環境」でも、「人間にとっては悪い」環境である。

轟音・豪風と寒さ・・・・
人の五感を破壊する勢いだ・・・・

 :
 :
 :

メーカーサポートを受けている間に、パチリ。

データセンタ

1ラック46U×3ラック分、フルにサーバが入っている。
安定稼動しているので、日頃の管理は非常に楽。

でも、トラブル発生時は「生きた心地がしない」のは俺だけか??

そう言えば、最近のトラブルは休日にしか起きない。
なぜだろう・・・・w

投稿時間: 20:57

玄箱ProFedora8のkernel アップデート

玄箱ProのFedora8化を紹介しているサイトで、またまたkernelのアップデートが出ていた。
   ↑ ペースが速い!!
今回はKernel-2.6.25-rc1がベース。
玄箱PROのソースがマージされているようです。

ようやく、玄箱Proも一般的なHWと認められた??ようです。

では、早速DLしてインストール。
非常に簡単にUPDATEが出来る。

本当に感謝です。

投稿時間: 00:24

玄箱HG Fedora8化への道 №4 (玄箱HGのデータ引越し 其の七)

玄箱HGをリカバリする前にバックアップを取った。
そのバックアップデータを玄箱HGに戻さなければならない。

その為には、sambaとmt-daapdのサービスを立ち上げる必要がある。
昔、作業した内容のままではmt-daapdの構築が出来なかった。
玄箱HG Fedora6でiTunesServer ← 多分、Fedora6用に作成されたパッケージだからでしょう。

http://koji.fedoraproject.org/packages/mt-daapd/0.2.4.1/5.fc8/ppc/mt-daapd-0.2.4.1-5.fc8.ppc.rpm
からmt-daapdを持ってきて、インストール。
※依存関係で足らないパッケージを入れる必要がある。 メモるの忘れたし・・・

rebuildしない分、簡単に作業できた(^^♪

そして、先日バックアップを取ったUSBのHDDをマウントして、一気に解凍。
時間は掛かるが、確実に復旧できる。

投稿時間: 00:05

玄箱Fedora8をFedora9-AlphaにUPDATE

初期の玄箱はFedora8にしたままで、何も設定を施していない。
FedoraのFTPサイトにはテスト版の「9-Alpha」が出ていた。

何も使っていないのなら、テスト的にUPDATEしてみようと思う。

1、必要なパッケージをwgetする
  # wget http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/test/9-Alpha/Fedora
/ppc/os/Packages/fedora-release-8.90-3.noarch.rpm
  # wget http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/test/9-Alpha/Fedora
/ppc/os/Packages/fedora-release-notes-8.90-1.noarch.rpm

  # rpm -Uvh fedora-release-8.90-3.noarch.rpm fedora-release-notes-8.90-1.noarch.rpm

2、yumやrpmのパッケージを最新にする。
  # yum update rpm\* yum\*

=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
glib2 ppc 2.15.4-2.fc9 development 1.2 M
initscripts ppc 8.63-1 development 1.6 M
libdhcp4client ppc 12:4.0.0-10.fc9 development 295 k
libevent ppc 1.3e-1.fc9 development 55 k
nspr ppc 4.7-1.fc9 development 137 k
nss ppc 3.11.99.3-1.fc9 development 1.2 M
openldap ppc 2.4.7-7.fc9 development 336 k
openssl ppc 0.9.8g-4.fc9 development 1.6 M
parted ppc 1.8.8-3.fc9 development 688 k
rpm ppc 4.4.2.3-0.1.rc1 development 1.2 M
rpm-build ppc 4.4.2.3-0.1.rc1 development 315 k
rpm-libs ppc 4.4.2.3-0.1.rc1 development 1.0 M
rpm-python ppc 4.4.2.3-0.1.rc1 development 72 k
yum noarch 3.2.11-1.fc9 development 550 k
yum-metadata-parser ppc 1.1.2-7.fc9 development 29 k
yum-utils noarch 1.1.11-1.fc9 development 52 k
Installing for dependencies:
dirmngr ppc 1.0.1-1.fc9 development 248 k
gamin ppc 0.1.9-4.fc8 development 136 k
gnupg ppc 1.4.8-1 development 2.0 M
gnupg2 ppc 2.0.8-3.fc9 development 2.6 M
gnutls ppc 2.0.4-2.fc9 development 394 k
gpgme ppc 1.1.6-2.fc9 development 318 k
libcurl ppc 7.18.0-1.fc9 development 157 k
libgcrypt ppc 1.4.0-1 development 248 k
libgpg-error ppc 1.6-1 development 72 k
libksba ppc 1.0.2-4.fc9 development 118 k
libtasn1 ppc 1.1-1.fc8 development 292 k
libusb ppc 0.1.12-12.fc9 development 33 k
pinentry ppc 0.7.4-1.fc9 development 65 k
pth ppc 2.0.7-6 development 98 k
pygpgme ppc 0.1-8.fc9 development 33 k
Updating for dependencies:
apr-util ppc 1.2.12-4.fc9 development 81 k
libdhcp ppc 1.99.7-2.fc9 development 74 k
libdhcp6client ppc 1.0.11-1.fc9 development 95 k
libuser ppc 0.56.7-1 development 489 k
mdadm ppc 2.6.4-3.fc9 development 633 k
mkinitrd ppc 6.0.28-4.fc9 development 100 k
nash ppc 6.0.28-4.fc9 development 161 k
neon ppc 0.28.0-2 development 124 k
nfs-utils ppc 1:1.1.1-4.fc9 development 322 k
nfs-utils-lib ppc 1.1.1-1.fc9 development 68 k
ntp ppc 4.2.4p4-2.fc9 development 1.4 M
openssh ppc 4.7p1-7.fc9 development 300 k
openssh-clients ppc 4.7p1-7.fc9 development 511 k
openssh-server ppc 4.7p1-7.fc9 development 288 k
perl-Net-SSLeay ppc 1.32-2.fc9 development 213 k
python ppc 2.5.1-21.fc9 development 5.0 M
python-ldap ppc 2.3.1-2.fc9 development 135 k
python-libs ppc 2.5.1-21.fc9 development 632 k
subversion ppc 1.4.6-2 development 2.5 M
sudo ppc 1.6.9p12-1.fc9 development 219 k
vsftpd ppc 2.0.5-21.fc9 development 147 k
wget ppc 1.11-1.fc9 development 579 k

Transaction Summary
=============================================================================
Install 15 Package(s)
Update 38 Package(s)
Remove 0 Package(s)

Total download size: 31 M
Is this ok [y/N]: y

ずいぶん多くのパッケージが新規でインストールされる・・・・

3、一気にupgrade
  # yum -y upgrade

  これも相当な数のインストールとアップデート。

4、Base Groupをアップデート ※これは必要ないかも?
   # yum groupupdate Base

  これも相当有った。 Install 172 Package(s)

5、ここで再起動しておく。

6、何かが違う・・・。
  SSHでログインすると「-bash: [: : integer expression expected」とmessageが・・・
  何のmessageか解らんし~~
  色々調査してたら、途中で玄箱の応答が無しに・・・・
  参った。

投稿時間: 01:15

玄箱HG Fedora8化への道 №3 (玄箱HGのデータ引越し 其の六)

玄箱HGも基本的なFedora8環境が出来た。

少しずつ環境を整えていきましょう。

1、先ずは、WebminをインストールしてWebから簡単に管理できるようにしましょう。

Webminはwww.webmin.orgから最新版をGET
おっと・・・
その前に、SSL通信が出来るようにperl-Net-SSLeayを先にインストールしておく。
   # yum -y install perl-Net-SSLeay

完了したら、Webminの最新版をwgetしてインストールする。
これで、安心してアクセスできる。

2、コマンドでメールが遅れるようにmailxをインストール。
   # yum -y install mailx

3、cpanのperlモジュールを簡単にインストールできるようにする。
   (rpmパッケージ化してインストールさせる)

   # yum -y install perl-ExtUtils-MakeMaker ← インストールされて無い場合。
    ※cpan2rpmに必要なExtUtils::MakeMakerインストール。

   # yum -y install cpan2rpm
    ずらずらとインストールされる。

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
cpan2rpm noarch 2.028-2.fc8.1 fedora 60 k
Installing for dependencies:
perl-Compress-Raw-Zlib ppc 2.005-3.fc8 fedora 58 k
perl-Compress-Zlib noarch 2.005-2.fc8 fedora 34 k
perl-HTML-Parser ppc 3.56-2.fc8 fedora 113 k
perl-HTML-Tagset noarch 3.10-6.fc8 fedora 15 k
perl-IO-Compress-Base noarch 2.005-2.fc8 fedora 53 k
perl-IO-Compress-Zlib noarch 2.005-2.fc8 fedora 135 k
perl-libwww-perl noarch 5.808-3.fc8 fedora 373 k

Transaction Summary
=============================================================================
Install 8 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 841 k


4、crondが使えるように必要なパッケージをインストール
   # yum -y install vixie-cron

インストールが終わったら、時間合わせをcrondで行わせる。
※ntpdで同期させるまでの必要な無いでしょう??

   # crontab -e
   1 1 * * * /usr/sbin/ntpdate ntp.dnsbalance.ring.gr.jp
   2 1 * * * /usr/sbin/hwclock -w

投稿時間: 21:50

玄箱HG Fedora8化への道 №2 (玄箱HGのデータ引越し 其の五)

無事Fedora7化できたら、次はFedora8へのupgradeの準備。

参考サイトはこれ

1、yumの不具合を修正(Fedora7 PPC版のyumで不具合が出ている為。)
   /usr/lib/python2.5/site-packages/yum/packages.py の
   30行目付近の"import Errors"の下に
   import md5
   を追加。

   658行目付近の"self.hdr[rpm.RPMTAG_SIGMD5]"下記の行の下に
   if not self.pkgid:
   self.pkgid = md5.new(str(self.hdr)).hexdigest()
   を追加。

   ※上記の内容で、正常に動かない場合は次のように変更すると動く場合がある。
   +++++++++++++++++++++++++++++++++++++++++++++++++
   self.pkgid = self.hdr[rpm.RPMTAG_SHA1HEADER] or \
      self.hdr[rpm.RPMTAG_SIGMD5]
   if not self.pkgid:
   self.pkgid = md5.new(str(self.hdr)).hexdigest()
   self.packagesize = self.hdr['size']
   self.__mode_cache = {}
   self.__prcoPopulated = False
   +++++++++++++++++++++++++++++++++++++++++++++++++
     ↓  ↓  ↓ 書き換え
   +++++++++++++++++++++++++++++++++++++++++++++++++
   self.pkgid = self.hdr[rpm.RPMTAG_SHA1HEADER]
   if not self.pkgid:
      self.pkgid = self.hdr[rpm.RPMTAG_SIGMD5]
   if not self.pkgid:
      self.pkgid = md5.new(str(self.hdr)).hexdigest()
   self.packagesize = self.hdr['size']
   self.__mode_cache = {}
   self.__prcoPopulated = False
   +++++++++++++++++++++++++++++++++++++++++++++++++

2、Fedora8の必要パッケージをGetする。
   Fedora8のPPCのサイトへ行き、次の2つをwget

  入手先
   http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/8/Fedora/ppc/os/Packages/
    や
   http://ftp.riken.jp/Linux/fedora/releases/8/Fedora/ppc/os/Packages/

   ・fedora-release-8-3.noarch.rpm
   ・fedora-release-notes-8.0.0-3.noarch.rpm

3、[2、]でwgetしたパッケージをインストール(UPDATE)
   # rpm -Uvh fedora-release-8-3.noarch.rpm fedora-release-notes-8.0.0-3.noarch.rpm

4、念のため掃除
   # yum clean all
    ※packages.pyの修正が成功していればエラーは出ない。


5、yumコマンドにて「yum」と「rpm」をFedora8のパッケージへupgradeする。
   # yum update rpm\* yum\*
    ※packages.pyの修正が成功していればエラーは出ない。
     エラーが出る場合は、何処かがおかしいはずw

6、一気にupgrade
   # yum -y upgrade

7、Base Groupをアップデート
   # yum groupupdate Base

8、一度、再起動。

9、Fedora8 になって公式から消えたパッケージ(rpm)を調べる。
   # yum install yum-utils  ← yumのユーティリティをインストール
   # package-cleanup --orphans
    Setting up yum
    kernel-2.6.21-1.3194.fc7.ppc

10、rpmデータベースの依存関係のチェック
   # package-cleanup --problems
   Setting up yum
   Reading local RPM database
   Processing all local requires
   No problems found

11、二重になっているパッケージの調査
   # package-cleanup --dupes
   Setting up yum

   重複パッケージが見つかったら、次のコマンドで消しておく。
   # package-cleanup --cleandupes

12、rpmdb の再構築
   # rm -f /var/lib/rpm/__* ; rpm --rebuilddb

13、必要であれば開発環境をインストール
   # yum groupinstall "Development Tools"
   Setting up Group Process
   Fedora-8-comps.xml 100% |=========================| 1.2 MB 00:00
   comps-f8.xml 100% |=========================| 1.2 MB 00:00
   Package gcc - 4.1.2-33.ppc already installed and latest version
   Package binutils - 2.17.50.0.18-1.ppc already installed and latest version
   Resolving Dependencies
   --> Running transaction check
   ---> Package diffstat.ppc 0:1.43-6.fc8 set to be updated
   ---> Package pstack.ppc 0:1.2-7.2.2 set to be updated
   ---> Package python-ldap.ppc 0:2.3.1-1.fc8 set to be updated
   ---> Package cvs.ppc 0:1.11.22-12.fc8 set to be updated
   ---> Package ccache.ppc 0:2.4-11.fc8 set to be updated
   ---> Package indent.ppc 0:2.2.9-16.fc7 set to be updated
    :
    :
    :
   perl-URI noarch 1.35-3.1 fedora 116 k
   qt ppc 1:3.3.8-9.fc8 fedora 3.8 M
   sudo ppc 1.6.9p4-3.fc8 updates 238 k
   systemtap-runtime ppc 0.5.14-1.fc8 fedora 34 k
   xorg-x11-filesystem noarch 7.1-2.fc6 fedora 5.5 k
   zip ppc 2.31-3.fc7 fedora 134 k

   Transaction Summary
   =========================================================================
   Install 75 Package(s)
   Update 0 Package(s)
   Remove 0 Package(s)

   Total download size: 56 M
   Is this ok [y/N]: y  ← [y]で一気にインストール

   その後、自動的に75個のパッケージがインストールされる。
   ※時期によってインストールされる数やパッケージが異なる場合があります。

14、Fedora8に適応したkernelに差し替えが出来れば、完璧ですね。
   今回は、Kernelの差し替えは無し・・・
   暇を見てkernelでも作りましょう。

投稿時間: 20:50

玄箱HG Fedora8化への道 №1 (玄箱HGのデータ引越し 其の四)

相当な時間を掛けて、玄箱HGのバックアップを取ることが出来た。
その他必要な設定Fileを探し、個別にバックアップ。

++++ その前に今回のハード構成 ++++++++++++++++++++++++++++++++++++++++
筐体  : 玄箱HG
HDD  : HITACHI Deskstar 164.7GB (Model:HDS722516VLSA80 SATA)
その他 : KURO-SATA
        ↑↑ これは、玄箱HGにSATAディスクを取り付ける為の変換基板。
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

インストールを行う前に、事前準備を行う。

1、玄箱HGを「EMモード」に切換える。
 再起動し、「DISK FULL」点灯時に電源ボタンを一回押し。
 起動後、echo -n 'NGNG' > /dev/fl3 を投入。
 これで、EMモードで起動出来る。
 ※これは、Fedora6化を行っていた為、上記の作業が出来る。

2、既存データの削除。
 HDDを取り外し、HDDを初期化する。
 一度、全てのパーティションを削除し、1つのパーティションを切る。
 そして、NTFSにてフォーマット。 ← 非常に時間が掛かる。
 フォーマットが終わったら、上記で作成したパーティションを削除。
 ※パーティションが切られていると、インストール作業が出来ない為。

 色々な方法でHDDの初期化は出来るが、今回はHDDをUSB化させる「デジタルカウボーイの
 DC-ACHD1/B
 を利用した。
 これは、SATA・IDE(3.5&2.5)に対応していて非常に重宝。
 購入してしばらく経つが、2年前ほど前にヨドバシカメラで2,980円で購入。

《お勧め》
 その他に、もっとも簡単なHDD初期化は、EMモード時に「mfdisk -c /dev/hda」でも初期化は
 可能です。

3、HDDの取り付け
 初期化が終わったHDDを玄箱にセットする。
 KURO-SATAを使っているので、IDEケーブルの引き回しに苦労したw

4、Fedora7をインストール。
 ん? Fedora8じゃないの? って思いでしょうが、Fedora8化にいきなり出来るKITが無いため、
 とりあえずFedora7化。
 できる!玄箱 Fedora化!!(F-7対応)から、「F4K Install Kit」を入手。
 手順に従い、インストール。
 今回のパーティション構成はこんな感じで構築
  ・/dev/hda1  基本領域 ・・・ 512Mbyte
  ・/dev/hda2  swap領域 ・・・ 512Mbyte
  ・/dev/hda3  Fedora領域 ・・・ 20Gbyte ← こんなには必要ないですw 10Gbyteでも充分
  ・/dev/hda4  /mnt ・・・・・・・・ 残り全部

 インストールが終わると、自動的に電源が落ちる。
 ※再起動するも、一回目は正常に起動しないため、一度コンセントを抜いてしばらく待つ。
   そして、起動。 デフォルトのパスワードで無事起動

5、環境整備
 Fedora7化が済んだら、とりあえず宅内環境に合わせる。
 rootのパスワード変更
 ユーザー作成
  :
  :
  :

投稿時間: 16:30

玄箱HGのデータ引越し 其の三

玄箱HGはFireServerとiTunes(mt-daapd)のサーバも兼用していた。
リカバリ前に気がついて良かった^_^;

早速バックアップを取ってみようと思う。
そのままコピーでは時間が掛かるし、途中でエラーが出る場合があるので、ちょいと面倒。
余ってるUSBのHDDをマウントして、圧縮しながら移動させようと思う。

該当ディレクトリまで降りて

# tar cvf バックアップ名.bak ターゲットディレクトリ

↑こんな感じで圧縮実行。

全部で70GB程度のデータがあるので、何時間掛かるのやら・・・
やりっぱなしで、寝てしまおう。

明日には終わってるでしょう。

投稿時間: 00:11

玄箱HGのデータ引越し 其の二

玄箱HGからDellSC420に引越しを行うため、昨晩DNSの設定を一部変更していた。
時間的にそろそろOKでしょう。

では早速作業することにする。

先ずは、玄箱HG(FedoraCore6)に入っているコンテンツを我が家のメインサーバであるDellSC420(CentOS4.6)に引越しを行う。

1、DellSC420にバーチャルドメインの設定を行う。
2、DellSC420にバーチャルドメインのメールアカウントを作成。
3、玄箱HGのコンテンツをバックアップ(tar cvf で圧縮)。
4、玄箱HGの各DBのバックアップ。
5、玄箱HGのバックアップをDellSC420に転送し、解凍(tar xvf で解凍)。
6、玄箱HGのバックアップDBをDellSC420に入れる。
7、DNSの切替を行い、玄箱HGからDellSC420に向ける。
8、コーヒーを飲みながら、DNSが切り替わるのを待つ。

TTLを600に変更していたので、10分程度で切り替わるはす。
切り替わったであろう時間にMTの管理画面にログインする。
玄箱HGとDevvSC420ではコンテンツの配置ディレクトリが違うので、新環境に合わせる。
※[設定] → [公開] →[ サイト・パス]の変更

念のため再構築を実行。
その後、完全に移行できているかを確認。

無事切り替わり完了。

※この投稿は新環境(DellSC420)で実施してみた。
 問題なく書き込みも出来た。

投稿時間: 22:39

玄箱HGのデータ引越し 其の一

最近、玄箱HGの動作が遅く感じるようになった。
OSもFedora6だし・・・・ そろそろバージョンアップも含め、再構築でも行ってみようと思う。

先ずは、瞬時にDNSが切り替わるようにTTLを替えておく。

$TTL 86400

  ↓↓↓

$TTL 600

引越しの実行は明日に行うことにしよう!!

投稿時間: 20:57

気分転換

委託契約をしている会社にマズイコーヒーがある。
今までは、近所のコーヒーショップで購入して飲んでいたが、一日数杯飲むと金銭的にキツイ・・・w

そこで、マズイコーヒーをチョットだけ美味しくさせる「品」を見つけた。

DAVINCI Classic Caramel syrup

ちょっとした気分転換には良いかも知れない。

投稿時間: 13:40

玄箱ProFedora8のUPDATE(Kernel-2.6.24)

玄箱ProFedora8のインストールKITを作った作者のサイトで、Kernel-2.6.24のKITが出ていました。
早速、UPDATEを実行

とっても簡単なKITで助かります。

投稿時間: 22:10